PDA

View Full Version : [ubuntu] libssh2 install



m3bik
April 30th, 2009, 06:04 AM
I'm trying to install libssh2 on my ubuntu server.

When I run ./configure I get this error message:

checking for OpenSSL... configure: error: Cannot find OpenSSL's <evp.h> or <hma.h>


I've ran:

apt-get install openssl

Everything appeared to install successfully, but I still get the same error message...

m3bik
April 30th, 2009, 10:36 AM
Do I maybe need to download the actual openssl source files instead of simply installing through apt-get?

m3bik
April 30th, 2009, 07:20 PM
I couldn't find openssl-dev anywhere. I installed libssl-dev and it appears to be working fine now...