PDA

View Full Version : [ubuntu] Can't select proper screen resolution



CeeDub
April 30th, 2009, 05:16 AM
I just installed Ubuntu 9.04 on a friends old laptop. The screen is capable of 1280x800 and 1024x768, but it is stuck at 800x600. I went in to change the xorg.conf file, but it was like this:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

and I'm not sure what to put in the screen section to make it work. It also says in the commented section that "settings here are ignored". Will modifying the xorg.conf file work anymore? What do I do to get the screen resolution right?

Wiebelhaus
April 30th, 2009, 05:17 AM
I'm trying to figure it out to man.

http://ubuntuforums.org/showthread.php?t=1143138

mal1958
April 30th, 2009, 05:41 AM
You might want to tell us what the video card or chipset is. Is it ATI, Invidia, etc...

That could help in getting a solution to your problem.

Mal

CeeDub
May 2nd, 2009, 01:23 AM
lspci shows this:



01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility M3 AGP 2x (rev 02)

Now what?

jmszr
May 2nd, 2009, 02:58 AM
CeeDub,

This is just a "worth trying":
xrandr -s 1024x768
Worked for me once, but it was a somewhat different situation.

Hope it helps.