PDA

View Full Version : [ubuntu] 9.0.4 and ATI Mobility Radeon



katchunga
April 29th, 2009, 07:27 PM
i've been using ubuntu 8.10 for a while and was very pleased with it. So when 9.0.4 was released I updated my 8.10 installation to 9.0.4. After reboot my screen was blank...appearently the graphic card is not supported any more? worked like a charm under 8.10. I am using a Hp EliteBook 8530p, ATI Mobility Radeon™ HD 3650

So I tried to install 9.0.4 from CD. Then the package manager did not work, had to use the command line to install packages. I've also had some issues with eclipse and ruby, Java...

After spending quite some time to get the basic stuff to work I still have trouble to find a driver for my graphic card. I cannot use a docking station or external monitor, and cannot find a suitable driver. I would very much like some help to find a driver that works and in the mean time I guess i have to install 8.10 again...

If you have any ideas or suggestions on how to find a working driver for ATI Mobility Radeon™ HD 3650 please let me know.

apocalypse80
April 29th, 2009, 08:15 PM
I have the same laptop and had the same problem, black screen with the driver from the repositories.

The solution was booting in recovery mode, dropping to root shell and running;
aticonfig --initial
aticonfig --acpi-services=off

the second command seems to be the key.

Later I upgraded to catalyst 9.4 from ati's website and it just continued working, I presume it kept the relevant settings.

Warning; 3D effects aren't that great with an ati card on any distribution, but they are horribly bad in 9.04 - be advised if you plan on using them.

katchunga
April 29th, 2009, 08:46 PM
Thank you for your answer

Could you please give me some more information on how you installed the driver. The URL to the site and maybe some short instructions about the installation process.

I was hoping to use some 3D effects but it is not that important, the most important thing for me is that I can use my docking station at work and that I can use ubuntu without putting to much effort on configuration and compiling drivers and stuff.

If someone have any answers to why 3D graphics (on ubuntu) is kind of bad on laptops using ATI Mobility Radeon I would appriciate an explanation.

apocalypse80
April 29th, 2009, 09:05 PM
I installed the proprietary driver that came with ubuntu 9.04 and rebooted, which earned me the black screen.
Then I solved that by using the commands above.

It should work fine if you run the same two commands after installing the driver but BEFORE rebooting.

If you plan on installing the driver from ati.com, look here;
https://help.ubuntu.com/community/BinaryDriverHowto/ATI

Worked for me.

aditirex
May 2nd, 2009, 01:08 PM
If you install the driver from ati.com , you still need to run aticonfig --acpi-services=off in recovery mode , otherwise you'll get the blank screen . I have a 8530p w/ 3650HD too .

trustnone
May 2nd, 2009, 03:42 PM
i am having the same problem but i cannot boot to recovery mode also.
When i get through the ubuntu loading screen: ubuntu image with loading bar on the bottom of the image.
I get a screen with lines on it.

And i cannot get to the recovery mode. When i press escape in the beginning i get to
grub> and none of the commands that you mentioned work there.

Please let me know how to get to recovery mode.

thanks a lot.