PDA

View Full Version : [ubuntu] 9.04 desktop shortcut?



creess1
April 28th, 2009, 03:02 PM
So i'm trying to make a desktop shortcut for world of warcraft. I already have wine installed and wow installed, and it works if i go to the wow.exe file, but i want to have a desktop icon i can just double click to make it work.

I saw this how-to: https://help.ubuntu.com/community/WorldofWarcraft

So i created this file with the following in a terminal:
/usr/share/applications/wow.desktop

then i paist in the information:

[Desktop Entry]
Encoding=UTF-8
Name=World of Warcraft
Name[hr]=World of Warcraft
Exec=wine /home/sean/.wine/dosdevices/c:/Program Files/World of Warcraft/Wow.exe
Icon=Wow-icon-scalable.svg
Terminal=false
Type=Application
Categories=Application;Game;
StartupNotify=false


but when i click on the file which is on the desktop, all it does is open it like a text document to edit, and doesnt run the program. What am i doing wrong?

creess1
April 28th, 2009, 03:20 PM
Just to update, i tried fixing this by adding ".desktop" to the end of the filename. Well it didnt fix it and now when i double click on the file it says "Could not display "/home/sean/Desktop/World of Warcraft.desktop"."The location is not a folder".

EDIT: alright i deleted it, remade it. Saved it to the desktop. Have the original problem again. When i double click it it opens it as a text document instead of running the program.

Why is something as simple as creating a desktop shortcut such a pain in the ***. Its things like this that make windows users go running back.

hotstovejer
April 28th, 2009, 03:23 PM
Sounds like you need to make that .desktop file executable, buddy.

Open up a terminal, cd to your Desktop folder, and type this
chmod +x nameoffile

That should make it executable, and not open up as a text file.

Hope this helps!

Thanks!

creess1
April 28th, 2009, 03:47 PM
ok, another dumb question.

i open a terminal. i do a "cd /home/sean/Desktop"
then i do a "chmod +x World of Warcraft"

and it says:

chmod: cannot access `World': No such file or directory
chmod: cannot access `of': No such file or directory
chmod: cannot access `Warcraft': No such file or directory


Do i put underscores in, or put it in quotes or something?

EDIT:
well i took the easy route for now and added underscores to the file name. Now when i double click the file it asks:
"Do you want to run "World_of_Warcraft", or display its contents?" and it gives the options "run in terminal" "display" "cancel" and "run". none of the options make it work. ALso i dont want this pop up box, i just want wow to start. I thought ubuntu was all about making linux easy mode. Maybe its just me, but creating shortcuts should be easier. like right click on executable, click "send to" then click "create shortcut on desktop". that would be perfect.

hotstovejer
April 28th, 2009, 04:19 PM
Well, you could always just go the GUI route and use Add To Panel to create the launcher, then drag it on the desktop.

Right click on a panel, and select Add To Panel. Select Custom Application Launcher. Type should be Application. Name it what you want. Click browse and navigate to the WOW.exe. Choose Open. Then, before the command back in the Create Launcher window, add wine at the very beginning. Ta dah!

Try that, and let us know!

Thanks!

creess1
April 28th, 2009, 04:30 PM
Well, you could always just go the GUI route and use Add To Panel to create the launcher, then drag it on the desktop.

Right click on a panel, and select Add To Panel. Select Custom Application Launcher. Type should be Application. Name it what you want. Click browse and navigate to the WOW.exe. Choose Open. Then, before the command back in the Create Launcher window, add wine at the very beginning. Ta dah!

Try that, and let us know!

Thanks!

yea i was doing this probably as you were typing. I noticed when i installed ventrilo that it created a shortcut on the desktop that worked. i put it in the top panel, right clicked on it and went to properties. basically copied everything except the location and file name and it worked, thought it had a funky springboard icon. Found out if i click the icon it shows when under properties, it lets you pick a different one.

But now i have a shortcut that "just works" and has the right icon.

Thanks for all your help.

hotstovejer
April 28th, 2009, 04:49 PM
No problem! Glad we could help!