PDA

View Full Version : No em monta DVD original



Xispa
April 25th, 2009, 08:00 PM
Tinc un ubuntu 8.04 i hem trobo que el sistema no és capaç de montar un DVD comercial. Altres tres ordinadors que també tenen un ubuntu 8.04 instal·lat tampoc reconeixen el DVD, mentres que ahir ho vaig probar en un ordinador amb un window$ XP i me'l va reconéixer perfectament. Comentar que amb altres DVDs/CDs no tinc cap problema, només hem passa amb aquest.

Tinc tots els còdecs instal·lats (libdvdcss2, libdvdnav4, libdvdread3 i tots els de gstreamer) i habitualment utilitzo tant el Totem com el VLC per reproduïr pel·licules. Tot i això, crec que el problema deu ser un altre, perquè quan introdueixo el DVD, el lector fa un soroll estrany, com si intentés llegir el DVD i no pogués i finalment, doncs no es monta.

L'he intentat montar manualment amb la instrucció

sudo mount -t iso9660,udf /dev/scd0 /media/cdrom0
i tampoc...

El meu fstab és el següent:


# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda1 :
UUID=94d225b9-9163-44cb-b731-5696e22d1f29 / ext3 relatime,errors=remount-ro 0 1
# Entry for /dev/sda3 :
UUID=35ea08ca-b24e-4896-baec-b25bea441812 /home ext3 relatime 0 2
# Entry for /dev/sda5 :
UUID=a44f3f8e-2a4b-4697-aa16-e3ab4b25376d none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0


També he fet un dmesg | tail i em surt:


[10564.318190] sr: Add. Sense: Spindle servo failure
[10574.224361] sr0: CDROM (ioctl) error, command: Test Unit Ready 00 00 00 00 00 00
[10574.224380] sr: Sense Key : Hardware Error [current]
[10574.224386] sr: Add. Sense: Spindle servo failure
[10584.181512] sr0: CDROM (ioctl) error, command: Test Unit Ready 00 00 00 00 00 00
[10584.181531] sr: Sense Key : Hardware Error [current]
[10584.181538] sr: Add. Sense: Spindle servo failure
[10594.394368] sr0: CDROM (ioctl) error, command: Test Unit Ready 00 00 00 00 00 00
[10594.394387] sr: Sense Key : Hardware Error [current]
[10594.394394] sr: Add. Sense: Spindle servo failure


No sé si servirà de gaire ajuda dient que el DVD és original i conté els tres primers capítols de la sèrie Roma.

He estat buscant amb en google i no n'he aconseguit treure'n l'entrellat.
Si em poguéssiu donar un cop de mà...

kimet
April 25th, 2009, 08:30 PM
Mirat aixó per si t'és útil:


http://www.geocities.com/cineencasa/zonasendvd.htm

Xispa
April 25th, 2009, 08:40 PM
Hola kimet,
la veritat és que no en tenia ni idea del tema de les zones. Com més va, més ràbia em fan les distribuïdores...

De totes maneres, he mirat al dors de la caixa i diu que és per la zona 2, així que, en principi, no hauria de tenir problema. No sé si hi pot tenir a veure (m'imagino que no, perquè sinó no l'hauria pogut reproduïr en un Window$), però a darrera la caixa també hi posa 'DVD protegido anti-copia'.

Per si serveix d'ajuda, em surt un error que diu 'Inappropriate ioctl for device' quan faig un sudo hdparm /dev/scd0:


/dev/scd0:
IO_support = 0 (default)
16-bit)
HDIO_GET_UNMASKINTR failed: Inappropriate ioctl for device
HDIO_GET_DMA failed: Inappropriate ioctl for device
HDIO_GET_KEEPSETTINGS failed: Inappropriate ioctl for device
readonly = 0 (off)
readahead = 256 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device


A veure què explica la wikipedia sobre ioctl... i continuant buscant a St. Google...

Xispa
April 25th, 2009, 09:16 PM
Ummm....
no sé que he fet (tret de les instruccions que he indicat en els anteriors posts), però ara sí que monta correctament el DVD i puc veure la carpeta VIDEO_TS amb tots els continguts (.VOB, .BUP i .IFO), però en obrir-lo amb el Totem em surt l'error:


S'ha produït un error
No s'ha pogut llegir des del recurs.


He probat d'obrir-lo amb el VLC i aquest se'm queda glaçat. Ho he provat amb les diferents opcions de obrir CD (menu i simple), obrir directori, obrir fitxer (seleccionant el .VOB) i res... més glaçat que una pedra.
Com he dit en el primer post, tinc tots els drivers libdvdcss2, etc. i gstreamer instal·lats...

També he probat de copiar la carpeta VIDEO_TS del DVD a l'escriptori (per probar de reproduïr-la amb el VLC sense tenir el factor distorsionant que es tracta d'un dispositiu) i em salta l'error:


S'ha produït un error en copiar «VIDEO_TS.VOB».
S'ha produït un error en copiar el fitxer a /home/jordi/Escriptori/prova.

Mostra més detalls
S'ha produït un error en llegir des del fitxer: Input/output error


Tot i això, anem avançant... ara almenys es monta.

ffp
April 26th, 2009, 07:06 AM
Hola xispa,

No es poden copiar els fitxers d'un dvd directament al disc dur, cal fer servir un ripejador? (dvd:rip) per exemple.
Per poder reproduir un dvd comercial cal instal·lar els paquets libdvdcss2, livdvdnav4, libdvdread4 i també ubuntu-restricted-extras (ull amb la jaunty), si fas servir 8.04 crec que son livdvdnav3 i livdvdread3 (per synaptic ho trobaràs). I apart els codecs (medibuntu es el summum).
Jo darrerament he tingut molts problemes amb dvd comercials recents, amb pixelats forts als menus, però carregar, és carregen tots

Xispa
April 26th, 2009, 11:14 AM
Ja ho he aconseguit !

després de mirar i mirar (instal·lar mplayer, gxine, etc.) ho he aconseguit establint el codi de regió del dvd a 2 amb la utilitat regionset:


sudo aptitude install regionset
regionset


Fet això, sembla que carregava el DVD correctament (tant el VLC com el mplayer), però en visualitzar-se es veien com tot de quadradets de colors. Almenys tenia so i hem reconeixia els capítols.

Després de buscar una mica més i descobrir que aquesta anomalía tenia alguna cosa que veure amb el libdvdread, he executat:


sudo /usr/share/doc/libdvdread3/install-css.sh


i voilà... ja puc veure la temporada 2 de Roma!