PDA

View Full Version : [ubuntu] 9.04 ati driver install problem



hedehodo
April 24th, 2009, 08:35 PM
i am kind of a newbie. but i can take i instructions well :) in ubuntu 9.04 i saw the option in add/remove packages to add the ati driver and catalyst control panel packages to ubuntu as i have x550 ati card i added those. it gave no errors in the adding. but when i restarted all i got was this corrupt screen. i think i just want to be able to rever back to the original for starters. how can i do that?
thanks for the guidance..

hedehodo
April 24th, 2009, 08:41 PM
i think i forgot to add that i am using a live usb disk with persistence..

Bateluer
April 24th, 2009, 09:14 PM
I've had this happen before, but cannot remember exactly how I resolved it. It required the configuration file for X to be rebuilt, x.conf.

Or you could turn off persisitance on the live USB disk.

necr0mancer
April 24th, 2009, 09:46 PM
I had the same problem, Im also new to linux. I have a ATI Radeon 4870x2 and i also did wat u did and my whole screen messed up. I had to re-install ubuntu... I dunno how to install new drivers for my gfx card on ubuntu. Any help?

LightningW
April 24th, 2009, 10:24 PM
I had the same problem (actually worst: very high lag, display settings frozing, no expanded desktop) with 4850 Toxic on 24" dual screens.
The solution is very simple. Just install the offical ATI display driver from amd.com but don't forget to deactive that bad thing before.

hedehodo
April 25th, 2009, 09:14 AM
"It required the configuration file for X to be rebuilt, x.conf."
how could i do that? i think i have to drop to terminal someway while the os is booting. but i dont know any keyboard shortcuts and any codes to do that?

gocek
April 25th, 2009, 09:42 AM
Well, although the driver doesn't work well for me, there's one thing I think you might be missing.

Try typing

sudo aticonfig --initial -f

just after installing the drivers, before reboot.

Or if your screen is messed up get into recovery mode and drop to shell as a root and then run

sudo apt-get remove xorg-driver-fglrx
so you will revert to the open source "radeon" driver

MichaelPalin
April 25th, 2009, 11:24 AM
I had this problem for ages and I have finally learn how to revert them.

- First of all, reboot the computer in Ubuntu recovery mode (http://2.bp.blogspot.com/_LKra8AUL9bY/SRlekW3RnSI/AAAAAAAAALg/Ucgm8hQealc/s400/20081111148.jpg). If you start it normally, the X starts and, as the graphics driver don't work, it crashes.

- When loaded select the option "root (http://www.psychocats.net/ubuntu/images/resetpassword03.png)" or, if you want, root with internet connectivity (although I don't think you'll need it at all).

- Now you are on console mode and you have to remove the privative drivers:

apt-get remove xorg-driver-fglrx

- Once removed, you have to reset the xorg.conf file, which is a configuration file for the graphical interface. It is in "/etc/X11" and, most likely, you will have various backup files that are automatically generated for various reasons (driver change, for example). You have to change an older one for the new one (the one which says that fglrx is to be used).

- Exit to recovery mode menu with command "exit" and resume normal boot.

If you want me to give you more details, feel free to ask. And, if you don't have an older xorg.conf (you should at least have xorg.conf~) I can write you a generic one.

By the way, I'm sorry to communicate you that any Radeon under HD2xxx wont have support for Catalyst 9.4 or newer and that Ubuntu 9.04, with XServer 1.6 wont work with Catalyst 9.3 or older. But the free drivers should work perfect for an old card like yours.

[EDIT] According to this tutorial (http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide), there is still hope for under R500 Radeon cards. Here (http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide#Post-Installation_Tweaks).

hedehodo
April 25th, 2009, 01:12 PM
well thank you all for the help.. but i got left nothing else to do but to remake the usb.. well at least in my knowledge that is.. i tried to install the ati drivers again but whenever i said aticonfig --initial it said that no cards detected... so i guess i will wait for a much more stable versions of the driver to come out..

vinics
April 25th, 2009, 01:19 PM
Thanks.. This works for me..

I am a ati radeon xpress 200M on AMD turion.. and a newbie!

:guitar:

hasplu
April 25th, 2009, 05:47 PM
I had this problem for ages and I have finally learn how to revert them.

- First of all, reboot the computer in Ubuntu recovery mode (http://2.bp.blogspot.com/_LKra8AUL9bY/SRlekW3RnSI/AAAAAAAAALg/Ucgm8hQealc/s400/20081111148.jpg). If you start it normally, the X starts and, as the graphics driver don't work, it crashes.

- When loaded select the option "root (http://www.psychocats.net/ubuntu/images/resetpassword03.png)" or, if you want, root with internet connectivity (although I don't think you'll need it at all).

- Now you are on console mode and you have to remove the privative drivers:

apt-get remove xorg-driver-fglrx

- Once removed, you have to reset the xorg.conf file, which is a configuration file for the graphical interface. It is in "/etc/X11" and, most likely, you will have various backup files that are automatically generated for various reasons (driver change, for example). You have to change an older one for the new one (the one which says that fglrx is to be used).

- Exit to recovery mode menu with command "exit" and resume normal boot.

If you want me to give you more details, feel free to ask. And, if you don't have an older xorg.conf (you should at least have xorg.conf~) I can write you a generic one.

By the way, I'm sorry to communicate you that any Radeon under HD2xxx wont have support for Catalyst 9.4 or newer and that Ubuntu 9.04, with XServer 1.6 wont work with Catalyst 9.3 or older. But the free drivers should work perfect for an old card like yours.

[EDIT] According to this tutorial (http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide), there is still hope for under R500 Radeon cards. Here (http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide#Post-Installation_Tweaks).

Thanks, man :) This worked just fine for me. The problem with the drivers still stands anyway - I can't watch normly youtube for example - it goes frame by frame....

ram4nd
April 26th, 2009, 07:46 AM
I have the same problem with my x200m, hope they solve it soon.

bebox
April 26th, 2009, 10:55 AM
can somebody explain to me what is:


aticonfig --initial -f?

gocek
April 26th, 2009, 10:10 PM
can somebody explain to me what is:

?

Briefly: modifies the /etc/X11/xorg.conf file to work with ATI driver and sets the default options.

More info:
http://www.debian-doc.org/man/1/a/aticonfig.html

aticonfig - parse an existing X-Server configuration file and modify it to operate with ATI products
ATICONFIG is a tool which should help you to create an (initial) X-server configuration file using the fglrx(4x) video driver. You can enable or disable special driver options.

--initial

Generate a default ATI device section in the configuration file which is capable of loading the fglrx driver.

-f, --force

Force aticonfig to generate default Monitor, Device and Screen sections even if the original configuration file has invalid settings in these sections. Only valid with --initial option.

bebox
April 27th, 2009, 01:04 PM
thank you!

emarkay
April 30th, 2009, 09:07 PM
Here's the main thread trying to figure this out:

http://ubuntuforums.org/showthread.php?t=1133931

ap90033
May 1st, 2009, 12:47 AM
I had the same problem, Im also new to linux. I have a ATI Radeon 4870x2 and i also did wat u did and my whole screen messed up. I had to re-install ubuntu... I dunno how to install new drivers for my gfx card on ubuntu. Any help?
Dude I thinks its awesome you are new to linux and after 6 days now you are still getting ignored and brushed off. That is so cool. Well unless i missed a post about how to actually successfully install the ati drivers. I bet you are fired up about waiting for an answer.... Just kidding, kinda... :)

I feel your pain I to have a 4870X2 and silly me i got the latest OS and ATI Driver and no go here... LOL
sigh

Neotelos
May 1st, 2009, 03:05 AM
You have the catalyst driver working with Xpress 200M?
I thought that model is no longer supported by Catalyst 9.4 and Catalyst 9.3 doesn't support the new X server?????

If anyone knows how to get Catalyst 9.4 working on an x1250, I would kill to know how they did it!

emarkay
May 1st, 2009, 02:32 PM
Dude I thinks its awesome you are new to linux and after 6 days now you are still getting ignored and brushed off. That is so cool. Well unless i missed a post about how to actually successfully install the ati drivers. I bet you are fired up about waiting for an answer.... Just kidding, kinda... :)

I feel your pain I to have a 4870X2 and silly me i got the latest OS and ATI Driver and no go here... LOL
sigh

Hey, not all of us search every post - and his post was buried in another thread. Imagine me - a many year Ubuntu user, now having to deal with a dead system after an updating to 9.04 - and not getting any help/ideas here specifically. I have filed a Launchpad bug report, and posted to 4 or 5 related forums, and it's a pretty big item - ATI card not working in Intrepid!

Anyway, sounds like a similar issue, and here's the thread that is focusing on this:
http://ubuntuforums.org/showthread.php?t=1133931

Biohmmwv
May 2nd, 2009, 11:02 PM
Well, although the driver doesn't work well for me, there's one thing I think you might be missing.

Try typing

sudo aticonfig --initial -f

just after installing the drivers, before reboot.

Or if your screen is messed up get into recovery mode and drop to shell as a root and then run

sudo apt-get remove xorg-driver-fglrx
so you will revert to the open source "radeon" driver

Thank you! I am a new Ubuntu user, and the potential dangers were not listed on the add/remove description.

d_fiant_1
May 3rd, 2009, 03:47 AM
I have tried everything...but there is still an issue. Running the 9.4 drivers and compiz and watching videos in minimized screen works great, fullscreen works alright....but as soon as you MAXIMISE any video window (Movie Player or VLC) the system crashes.

I'm beginning to wonder after a week if it would be better just going back to Ubuntu 8.10 because there are no real improvements to be gained from moving to Ubuntu 9.04 as you would expect

40-Dan
May 5th, 2009, 02:06 PM
I was excited to see this advice. Unfortunately, it did not work in my case. Running "apt-get remove" says that the offending drive is not installed, so there's nothing to do. I reverted my xorg.conf to each of two backups, but still have the same problem. In fact, NONE of my xorg.conf files appears to make any mention of fglrx at all.

Does anyone have any other ideas? I really don't want to reinstall again.

Thanks
Dan


I had this problem for ages and I have finally learn how to revert them.

- First of all, reboot the computer in Ubuntu recovery mode (http://2.bp.blogspot.com/_LKra8AUL9bY/SRlekW3RnSI/AAAAAAAAALg/Ucgm8hQealc/s400/20081111148.jpg). If you start it normally, the X starts and, as the graphics driver don't work, it crashes.

- When loaded select the option "root (http://www.psychocats.net/ubuntu/images/resetpassword03.png)" or, if you want, root with internet connectivity (although I don't think you'll need it at all).

- Now you are on console mode and you have to remove the privative drivers:

apt-get remove xorg-driver-fglrx

- Once removed, you have to reset the xorg.conf file, which is a configuration file for the graphical interface. It is in "/etc/X11" and, most likely, you will have various backup files that are automatically generated for various reasons (driver change, for example). You have to change an older one for the new one (the one which says that fglrx is to be used).

- Exit to recovery mode menu with command "exit" and resume normal boot.

If you want me to give you more details, feel free to ask. And, if you don't have an older xorg.conf (you should at least have xorg.conf~) I can write you a generic one.

By the way, I'm sorry to communicate you that any Radeon under HD2xxx wont have support for Catalyst 9.4 or newer and that Ubuntu 9.04, with XServer 1.6 wont work with Catalyst 9.3 or older. But the free drivers should work perfect for an old card like yours.

[EDIT] According to this tutorial (http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide), there is still hope for under R500 Radeon cards. Here (http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide#Post-Installation_Tweaks).

devilishlynice
May 12th, 2009, 10:56 AM
Thanks. This helped me.:popcorn:

zika
May 12th, 2009, 11:15 AM
just my .05$: with 9.04, Asus AH3650(a.k.a.ATI HD3650) 512M, the best results (no Compiz working yet ...) I've got without xorg.conf.

newenglandcs
May 14th, 2009, 09:27 PM
I had a similar problem with an ATI HD x1650 (I think that's the model no). I used Admin->Hardware Drivers to install the ATI driver and after reboot, I got the messed up screen and couldn't login or do anything. I followed gocek's recommendation, to revert back to the open source video driver and it worked.

On the Grub boot loader screen, choose the option for your kernel in recovery mode. From the recovery menu, choose the netroot option (terminal with network) and run the command.

sudo apt-get remove xorg-driver-fglrx

Then, exit or quit and resume normal boot. Of course, this doesn't fix the problem with ATI's driver, but the open source driver seems to work okay for my card.

ap90033
May 15th, 2009, 03:02 AM
I had a similar problem with an ATI HD x1650 (I think that's the model no). I used Admin->Hardware Drivers to install the ATI driver and after reboot, I got the messed up screen and couldn't login or do anything. I followed gocek's recommendation, to revert back to the open source video driver and it worked.

On the Grub boot loader screen, choose the option for your kernel in recovery mode. From the recovery menu, choose the netroot option (terminal with network) and run the command.

sudo apt-get remove xorg-driver-fglrx

Then, exit or quit and resume normal boot. Of course, this doesn't fix the problem with ATI's driver, but the open source driver seems to work okay for my card.

Well guess its back to Windows.

U2XS
May 25th, 2009, 07:41 PM
I had the same issue. I have an ATI X1250 on my laptop and Catalyst created a new driver set (9.4) which is incompatible with my hardware. Just go into the command line partition and type


sudo apt-cache search fglrx

Then the driver should look something like xorg-fglrx-driver. Then purge the package


sudo apt-get purge package name

ap90033
May 26th, 2009, 04:32 PM
Thanks, but how does that install the driver to get 3d working?

Citadel1980
May 29th, 2009, 07:55 PM
With all these problems with ATI graphics cards, can someone recommend a card that will work with a 2.75 year old Dell Dimension E510 - 3 GB RAM, E177 FP monitor, 250 GB hard drive and an ATI X300 graphics card?

I'm always burning the newest versions of some distro's livecd hoping that this is the one that will work (all bells and whistles) but it always comes down to ATI and its X300.

I don't have much money to drop into this card but I would pay for something if it can take me out of this ATI hell!

zika
May 29th, 2009, 08:33 PM
I had the same issue. I have an ATI X1250 on my laptop and Catalyst created a new driver set (9.4) which is incompatible with my hardware. Just go into the command line partition and type


sudo apt-cache search fglrxThen the driver should look something like xorg-fglrx-driver. Then purge the package


sudo apt-get purge package name
Having xserver-xorg-video-fglrx installed (that is what that command will show) does not mean that it is being used. For example, on many Ubuntu machines You have a bunch of drivers xserver-xorg-video-* for cards that are not and will never be in that machine. If You want to prevent driver from being used change xorg.conf, clear it from kernel and do dpkg-reconfigure ...