View Full Version : [ubuntu] Upgraded 9.04 on wrong Kernel? GRUB can't boot

April 24th, 2009, 07:57 PM
I had issues with the latest kernel in Ibex (mainly graphics related) so have been using 2.6.27-7-generic. I upgraded to 9.04 forgetting I was on an older kernel and now GRUB won't boot. I have the option to boot older versions from GRUB but that means I'm stuck on Ubuntu 8.10...

Pretty stupid on my behalf. I've tried running update-grub but the problem persists.

Any ideas?


April 24th, 2009, 08:15 PM
have the same problem ;

the upgrade went very easely onlin like i did with previous 2 versions without big problems
but this time ;
Bug Int 14 CR2 ffffb0f0
Edi 0000000...
Eby 000000046
errr 000000...
Stack c011a26e...

can work with linux old = 8.10

foud some explanation : it seems to be a regression ... I really don't understand this and what can I do ?

April 24th, 2009, 08:38 PM

I've tried running update-grub but the problem persists.

Try this:

cd /boot/grub
sudo mv menu.lst menu.lst.old
sudo update-grub

If this did not solve your problem:

In order to get a clearer picture of your setup, download the Boot Info Script to your desktop:


Then open a terminal (Applications > Accessories > Terminal) and type:

sudo bash ~/Desktop/boot_info_script*.sh

That will create a "RESULTS.txt" file in the same directory from where the script is run, namely your desktop; please copy/paste the contents of the RESULTS.txt file to your next post, (use the code tags).

April 24th, 2009, 08:41 PM
frevh: Could you start a new thread for your problem? Trying to solve two cases in one thread usually is very confusing. Thanks.

April 24th, 2009, 09:18 PM
ok I understand 'll try

April 24th, 2009, 09:33 PM
can't find how to start a niew thread:(

April 24th, 2009, 09:44 PM
can you folow me on this new thread?:confused:


May 14th, 2009, 09:55 PM
Very late reply, apologies. The install seemed really quick so when prompted to "upgrade" again on the old kernel I did and it worked. I'm assuming it was just a bad/faulty upgrade...

Thanks for all the help though :)