View Full Version : [ubuntu] OS can't find installed software after upgrade

April 24th, 2009, 11:38 AM

I upgraded to Jaunty while it was still in Beta and got some bugs. Hoped that they'd be fixed with software update but sadly most have remained.

First problem is that the OS can't find the program Vuze anymore. It is installed and I reinstalled it using Synaptic, but the shortcut in the Applications menu doesn't do anything.

When trying to load it from a terminal, I get

exec: 11: /usr/lib/jvm/java-6-openjdk/jre/bin/java: not found

And the auth.log says

CRON[27231]: pam_unix(cron:session): session opened for user root by (uid=0)
dbus-daemon: Rejected send message, 1 matched rules; type="method_call", sender=":1.42" (uid=1000 pid=3676 comm="/usr/lib/indicator-applet/indicator-applet --oaf-a") interface="org.freedesktop.DBus.Properties" member="Get" error name="(unset)" requested_reply=0 destination=":1.178" (uid=0 pid=27231 comm="/USR/SBIN/CRON "))
CRON[27231]: pam_unix(cron:session): session closed for user root

Anyone got a hunch on how I could get Jaunty to find Vuze again?


April 24th, 2009, 11:48 AM
Sounds like the short cut is broken. Try opening it from the command line first.


It should run and if not there will be error displayed in the terminal. If it doesn't run then run the next command.

which vuse

That command will show you the path to the vuse program. Copy the full path and run it in the terminal.

To fix your short cut right click on Applications> Edit Menus> Applications> Internet> Vuse and click properties. Put the full path from the command above into the command box, save and test.

This could be some bigger issue since you upgraded. I prefer doing a clean install instead of an upgrade.

April 24th, 2009, 11:59 AM
Thanks for the tip!

However, the command "which vuze" does give me an adress (/usr/bin/vuze) but when I type that path in the terminal it gives me the same error as before, i.e:

exec: 11: /usr/lib/jvm/java-6-openjdk/jre/bin/java: not found

The idea of a clean install is tempting, but wouldn't I lose all my data and applications?

April 24th, 2009, 12:05 PM
It looks like java is not installed, have you checked your java environment?

clive littlewood
April 24th, 2009, 12:10 PM

Search for java 6 in synaptic and install then you should be good to go !!


April 24th, 2009, 12:26 PM

Search for java 6 in synaptic and install then you should be good to go !!


Thanks! There are several files available in Synpatic, some of which are already installed. Which one(s) should I get?

April 24th, 2009, 12:43 PM
OK, Nevermind! I found it!

Installing Java indeed fixed my problem. Why it had been uninstalled when I upgraded remains a mistery, though...

Thank a lot!

clive littlewood
April 24th, 2009, 12:51 PM
Your very welcome !!!! :)


April 24th, 2009, 10:11 PM
Installing the openjdk-6-jdk package solved my problem.

April 30th, 2009, 02:45 PM
Same problem here even after reinstalling java.