PDA

View Full Version : [ubuntu] Get volume buttons to control PCM



pissedoffdude
April 24th, 2009, 05:37 AM
I recently updated to jaunty and I'm liking it so far, but I've one problem: I can't seem to get my volume buttons to control the PCM (they're controlling master volume). In previous versions, I was able to do this by going to System>Preferences>Sound and setting PCM as default there. However, in jaunty, PCM is no longer an option and all that appears is master. Anybody know a solution for this?

inobe
April 24th, 2009, 05:48 AM
i don't know much about System>Preferences>Sound, never went there.

you can control pcm from right clicking volume control and selecting "open volume control"

pissedoffdude
April 24th, 2009, 06:08 AM
i don't know much about System>Preferences>Sound, never went there.

you can control pcm from right clicking volume control and selecting "open volume control"

Yeah, but I'm trying to get my keyboard buttons to control the pcm instead of the master. Thanks for the input though.

inobe
April 24th, 2009, 06:22 AM
you can try selecting another device from the drop down menu.

remember the default device encase.


i was able to bring up multiple selections selecting HDA intel (alsa mixer)

pissedoffdude
April 24th, 2009, 06:39 AM
you can try selecting another device from the drop down menu.

remember the default device encase.


i was able to bring up multiple selections selecting HDA intel (alsa mixer)

Done that, but nothing about the keyboard controlling pcm. My sound is working perfectly, its just that I'm just trying to modify the channel that my keyboard volume buttons use.

inobe
April 24th, 2009, 06:47 AM
what happens after selecting pcm then going to keyboard shortcuts ?

system> preferences> keyboard shortcuts

pissedoffdude
April 24th, 2009, 06:55 AM
what happens after selecting pcm then going to keyboard shortcuts ?

system> preferences> keyboard shortcuts

The thing is, going there allows me to change the volume only for the master channel, not pcm. I used to be able to modify this under system>preferences>sound before.

inobe
April 24th, 2009, 07:04 AM
it's working fine for me, i can successfully lower and raise pcm with my keyboard.

>>click<< (http://www.itsyourpc.org/duane/files/Screenshot1111.jpg)

pissedoffdude
April 24th, 2009, 07:16 AM
it's working fine for me, i can successfully lower and raise pcm with my keyboard.

>>click<< (http://www.itsyourpc.org/duane/files/Screenshot1111.jpg)

Problem solved! Thanks for your help. I must've overlooked the options in system>preferences>sound the first time, as selecting the last option for the device gave me the list of channels to control.

inobe
April 24th, 2009, 07:19 AM
your welcome.




enjoy

http://ubuntuforums.org/showpost.php?p=7131999&postcount=4

fabiosl
August 7th, 2009, 11:03 PM
This thread Helped me. :D I'm using Hardy, instead...