View Full Version : [ubuntu] Can't enable 3D with a GeForce2 Pro

April 23rd, 2009, 07:09 PM
I installed Ubuntu 9.04 and found that unlike in 8.04, I was unable to enable 3D. I tried using synaptic to install the NVidia driver that supports the GeForce2 series cards, but the driver would not load. I tried the NVidia configuration program, which said:

You do not appear to be using the NVIDIA X Driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X Server.

nvidia-xconfig didn't exist on my system. I installed it from Ubuntu's site. It ran once, altered my xconfig file (later causing my xserver not to run at all), and then somehow vanished from my system!

So how exactly do I get 3D working on my system?


April 23rd, 2009, 07:13 PM
Every time I install video drivers on my laptop, I get a error messages and other claims that the installation didn't work, but when I restart the system everything is installed, activated, and working fine.

Try a reboot before getting into anything more complicated.

April 23rd, 2009, 08:30 PM
Long since rebooted. No longer have a working X Server.

April 26th, 2009, 01:58 PM
No other suggestions whatsoever?

April 26th, 2009, 02:33 PM
I tried to get my Nvidia driver to load as well and it didn't work. I found a suggestion for a previous version of Ubuntu to use Envyng, which I found with Synaptic. I used that tool in terminal mode, rebooted, and the driver is there.

Good luck.