PDA

View Full Version : [ubuntu] Nvidia + LCD Samsung = out of range



emitrax
April 21st, 2009, 03:58 PM
Hi,

this problem is driving me crazy, especially because I use
this computer for work.

I have the following video card

00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6150SE nForce 430 (rev a2)

The following monitor
ASUS VB171D

The following driver installed
nvidia-glx-180-dev

The following xorg.conf (which I have changed and tried with different modes and refresh range
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Wed Nov 26 11:27:46 PST 2008


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
# Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
#Driver "vesa"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Gdm runs fine, but after I log in, everything goes black and monitor prints out an error message "Out of range".

Please, help.

boutch55555
April 21st, 2009, 05:18 PM
Hi
I've been experiencing issues with the 180 nvidia driver as well, with all my cards (8800GTS, 8400GS, 7600GT and 6600). I would suggest using the 177 or 173 driver instead.

emitrax
April 22nd, 2009, 08:55 AM
I tried both of those but nothing. This problem is driving me crazy as I use the computer for work and can't waist too much time fixing it.

Damn updates!

Any other suggestions?

boutch55555
April 22nd, 2009, 03:18 PM
It could a frequency problem, since none are declared in your xorg.conf. The "Monitor" section in mine looks like this :

Section "Monitor"
Identifier "Monitor3"
VendorName "Unknown"
ModelName "DELL P1110"
HorizSync 30.0 - 121.0
VertRefresh 48.0 - 160.0
EndSection

you could try different values and see if it changes something.

By the way, does it work with the "nv" driver instead of nvidia ?? If so, you could try to have the gnome display manager to detect the proper frequencies and then manually change the driver back.

Also, I don't have the whole

SubSection "Display"
Depth 8
Modes "1280x1024" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
....

in the "Screen" section of my xorg.conf, so it looks like this :

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "CRT-0: 1800x1440 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Hope this helps...

EDIT

Just plugged back a unused computer containing a 7600gt plugged into a 17in samsung syncmaster, with the nvidia driver working. Here are the "Screen" and "Monitor" sections :

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "metamodes" "CRT-0: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

emitrax
April 22nd, 2009, 03:36 PM
If you are talking about Detect Display in Screen Resolution, in gnome, it does not work. It says unknown.

By using the menu of the monitor though, I get under information menu the
following info: VGA 800x600 37Khz 60Hz VB171D.

Yes. I'm working with 800x600 right now!

I tried with different modules version of nvidia, but nothing.
The current Xorg is the following, generated with nvidia-xconfig.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Mon Mar 2 12:45:55 PST 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"

#Driver "nvidia"
Identifier "Device0"
#Driver "nvidia"
Driver "vesa"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "True"
SubSection "Display"
Depth 24
Modes "1024x768" "1028x1024"
EndSubSection
EndSection


Working with vesa right now.

boutch55555
April 22nd, 2009, 05:20 PM
now you got the right frequencies, try :
Alt+F2
gksu gedit /etc/X11/xorg.conf

replace the "Screen" section with one of the two from my previous post (replacing 1800x1440 in the first one by either 1280x1024 or 1024x768 )

In the "Device" section, unquote the first #Driver "nvidia" (you can remove the second one) and quote the Driver "vesa"

restart X

If it still doesn't work, I'm out of ideas...