PDA

View Full Version : [ubuntu] Amarok 2 Wont play mp3s



betterthanjordan79
April 20th, 2009, 10:28 PM
hi i installed 9.04 beta a few days ago and have been havin problems wit amarok 2.it opens and seems to operate fine but it will not play mp3s(and possible no other music-i havent tried). anyone able to help me with this problem r anyone else having this problem???

Thanks in advance
Daniel

inobe
April 20th, 2009, 10:45 PM
are you getting any errors Daniel ?

have you checked the obvious like sound/mixer levels, also did you install restricted extras .....

is this an up grade to 9.04 ?

betterthanjordan79
April 20th, 2009, 10:53 PM
yes i have done both-rythembox is workin fine so i assume there using the same thing...no this was a clean install.

inobe
April 20th, 2009, 11:01 PM
so you assume that your choice of music is playing except you hear nothing ?

edit: i see it's not kubuntu, my bad

seems that amarok may be missing a requirement, did you follow a guide similar to this

http://monespaceperso.org/blog-en/2009/03/15/how-to-install-amarok-2-on-ubuntu-810/

betterthanjordan79
April 20th, 2009, 11:07 PM
no im runnin ubuntu 9.04 as shown in my screen shot,also im runnin amarok 2 as also shown.what happens is that it tries to play a track but just jumps past it till playlist is completed...

http://g.imagehost.org/0816/Screenshot.png

fooman
April 20th, 2009, 11:16 PM
do you have the ubuntu-restricted-extras package installed (probably need libxine1-ffmpeg as well)?

if not, try opening a terminal (applications > accessories > terminal) and type or copy/paste the following command:


sudo apt-get install libxine1-ffmpeg ubuntu-restricted-extras

after they install, close amarok if it was open....then restart it.

hope that helps

inobe
April 20th, 2009, 11:18 PM
so you assume that your choice of music is playing except you hear nothing ?

edit: i see it's not kubuntu, my bad

seems that amarok may be missing a requirement, did you follow a guide similar to this

http://monespaceperso.org/blog-en/2009/03/15/how-to-install-amarok-2-on-ubuntu-810/

:)

betterthanjordan79
April 20th, 2009, 11:26 PM
do you have the ubuntu-restricted-extras package installed (probably need libxine1-ffmpeg as well)?

if not, try opening a terminal (applications > accessories > terminal) and type or copy/paste the following command:


sudo apt-get install libxine1-ffmpeg ubuntu-restricted-extras

after they install, close amarok if it was open....then restart it.

hope that helps

that was actually my problem...i though i had installed them already...now i feel like a fool...anyways thanks for your help inobe and also for ur help fooman!!!

john stiles
April 20th, 2009, 11:29 PM
I recall I installed the lame package to get Banshee to play nicely with jaunty. I'm sure the actual release will iron out the usual non-free issues.

smokeslikeapoet
April 21st, 2009, 02:59 PM
I got mp3 support and playback working with Amarok 2 on Jaunty (not Kubuntu) by installing these packages:


sudo aptitude install libxine1-ffmpeg kubuntu-restricted-extras phonon-backend-xine

mrbinitie
April 23rd, 2009, 06:04 PM
Yes that does work.

fr0gg
April 30th, 2009, 07:01 PM
Hey guys, I'm having difficulty getting Amarok to play my music files..It's loaded all of the contents of my Ipod, but when I try and play, i get a message that reads "Audio Output Unavailable: the Device is Busy xine parameters:" I'm fairly certain it's something strange with my X-fi, just downloaded the drivers creative released, and audio works otherwise, just not in Amarok.
Any suggestions?
Thank you.

It seems the x-fi drivers are a bit dodgy, but they're working now, still no luck with amarok though

Nightreaver1986
August 13th, 2009, 09:35 AM
Yeah, the command here is what worked for me too. Depends on what kind of iPod you're using, but iPods are touchy things on Linux anyway. Maybe try reading one of the iPod support threads, see if this is a problem discussed somewhere in there?


sudo aptitude install libxine1-ffmpeg kubuntu-restricted-extras phonon-backend-xine