View Full Version : [ubuntu] .deb packages require other lib-packages?

April 20th, 2009, 11:56 AM

I've installed Ubuntu 8.04, and read all documentation on the site of Ubuntu. It seemed that installing packets of .deb extension is like exe in windows. But it appears matters are not like this.

I've downloaded RealPlayer .deb package and expected to have it install, but again the installer shows me lib... is lacking, the thing is not satisfactory.. and this happens with other packages too.:(

I have an internet connection in my workplace, but I cannot connect to repositories due to some "gateway" and "filter" restrictions, I think, in my network.

Who can explain me what's happening and how to solve this?

Thanks in advance.

April 20th, 2009, 12:08 PM
debs are kinda like setup.exe in terms of use but in terms of structure they're more like .zip files that auto extract to set locations. most programs have dependancies. this is an efficient way of doing things in terms of filesize etc. for example, a music player and a video player can then share the same audio playback engine. every program can use the same method for downloading plugins or updates, and all that sorta stuff.

you have a number of options i guess: you could open your firewall to the port apt uses at work or get someone to do it for you, you could use an open internet connection elsewhere, or you could download all the required .deb dependencies manually. you should be able to find everything you need at packages.ubuntu.com although this can be a tiresome way of installing software. you'll be better off trying to get synaptic to work.

do you use a proxy at work? if your webbrowser works, synaptic should work. if you have to use a proxy then you get set it in the synaptic preferences or probably system wide with the network manager or something.

April 20th, 2009, 12:12 PM
I've downloaded RealPlayer .deb package

The good news is that you don't need to. Realplayer is available through Synaptic if you connect to the Medibuntu (http://www.medibuntu.org/) repository.

April 20th, 2009, 12:14 PM
Thanks for quick reply. The browser is working, I have a gateway+firewall of the network, but the archives.ubuntu.com is unreachable. I'll talk with the network administrator for this to configure where is the block.

Nevertheless, many thanks!

April 20th, 2009, 12:15 PM
I've downloaded RealPlayer .deb package

Normally you can get Realplayer through Synaptic if you connect to the Medibuntu (http://www.medibuntu.org/) repository. Your work network may be blocking ftp though, I know mine does. Try going to System > Software sources and see what alternative servers you can ping.

EDIT: Gah! that was supposed to be an edit, not a repost? What happened there?

April 20th, 2009, 12:35 PM
Yeh there is no one true binary package installer in linux, so we use either .deb, .rpm or .tar.
All are more like zip archives, in order to keep the system from having errors by installing the same packages each time the dependencies are kept as separate packages, this is also good for space too.
Mind you we do have shell installers too, but typically they are terminal oriented.
There is an advantage and disadvantage to this system, on one hand it keeps down the clutter but on the other its not that good to have up to 12 dependencies when you cant use the internet.
But its gotten better, dependency hell is a lot less common these days and you typically dont need a lot of packages anymore.

April 20th, 2009, 01:03 PM
Thanks all for responses.
I have put all the credentials for connecting by synaptic to packages servers but in vain. The machine tells me "Error 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )".

Do you think this is solvable problem without much changing the server's settings?

April 20th, 2009, 03:10 PM
Do you think this is solvable problem without much changing the server's settings?

Depends how your proxy is set up. You might get full access if you point Ubuntu at your proxy and provide your user/pass. Or you might not. You'd have to talk to whoever runs your network.