View Full Version : [ubuntu] NVIDIA Driver Problem - please help

April 18th, 2009, 02:55 PM
I am successfully dual booting Ubuntu 8.10 alongside windows vista (not using wubi). when i was booting from a live usb (not persistent) i could go to hardware drivers and install any nvidia driver for my GEFORCE 7000m (which allowed me to go from a resolution of 800x600 to alot higher) and then goto appearance - effects and then choose the effects and they turned on and worked perfectly. I then installed from that usb but none of the drivers are working. every time i install a new driver then restart, i get an error message saying that ubuntu is running in low graphics and that it couldnt find the nvidia kernel module. from there i have to set my display back to the generic default and reboot. i need to use the driver to give me more resolution options as without the driver, the highest resolution is 800x600. i also tried using ENVY but the same thing is happening. i am using a HP G6000 and an NVidia Geforce 7000m / 610m

Any Help At All Is Appreciated

April 18th, 2009, 05:39 PM
*bump *bump

April 18th, 2009, 06:02 PM
Post your xorg.conf please.

April 18th, 2009, 06:25 PM
# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

Section "Module"
Load "dri"
Load "GLcore"

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"

is there any particular way to install drivers for the Geforce 7000m?
is there any way to sweep and erase all the remains of older drivers?
is there a way to restore ubuntu to a fresh install state?
is this fixed in Jaunty Jackelope?

April 18th, 2009, 06:30 PM
Ok so install the nvidia drivers like normal. before rebooting opn your xorg.conf and mke sure nvidia driver is set under driver. And yes i am not having that problem with 9.04.

April 18th, 2009, 06:44 PM
so just goto hardware drivers and install 177? or do i use envy?

btw, bdfore i install the drivers, how do i remove all my older drivers?

thx for the help

April 18th, 2009, 07:30 PM
easiest way is to use envy to uninstall old drivers.
Actually you will need nvidia driver 180 cause it supports this card. go to http://ubuntuforums.org/showthread.php?t=990978 and follow the directions should fix your issue

April 18th, 2009, 08:02 PM
i uninstalled all drivers
downloaded 180.44
pressed ctrl+alt+f1
stopped gnome
typed "sudo sh ./NVIDIA.............pkg1.run"
installed it and allowed it to rewrite my xorg.conf
(it said sumthing about not being able to find the write kernel on the website and that it would have to write its own. i allowed it to write its own)
when it was installed i restarted gnome and rebooted with "sudo reboot"

when it had rebooted and had just passed the part where the loading bar fills up with orange, it said something about not being able to find a resume image.
this flashed a few times and then it said that;

(EE) Failed to load module "type1" (module does not exist,0)
(EE)NVIDIA(0):Failed to load the NVIDIA kernel module!
(EE)Screen(s) found, but none have a usable configuration

then it said that it was in safe graphics mode and asked if i wanted to reconfigure my x server.

i reset the xorg to its default and rebooted and everything was back to where it started?

any suggestions? 177 worked perfectly on my usb live flash drive.

April 18th, 2009, 08:30 PM
Bump view above post

April 18th, 2009, 09:44 PM
bump two posts ago?

April 19th, 2009, 01:41 AM
hmmm....there is a newer driver 180.51 . But did you try
sudo dpkg-reconfigure xserver-xorg

i also had a problem similar and it had to do with acpi http://www.amitsrivastava.net/2008-03-23-hibernate-suspend-resolved-ubuntu-gutsy-nvidia-dell-vostro/comment-page-1/

April 19th, 2009, 07:26 AM
Follow these steps:

1) Download latest driver


3) sudo /etc/init.d/gdm stop

4) sudo apt-get remove Nvidia*

5) sudo sh ./Nvidia.......

6) sudo /etc/init.d/gdm restart

You should have everything back to normal now.

April 19th, 2009, 08:06 AM
Why don't you just install the nvidia-glx-180 driver from the Ubuntu repos?
Remove all nvidia drivers that you installed using envy, or that you installed from nvidia.com
Then hit ctrl + alt + F2 to get to a virtual terminal. The login, and run:

sudo /etc/init.d/gdm stop
sudo apt-get install nvidia-glx-180
sudo nvidia-xconfig
sudo /etc/init.d/gdm start

Then run:

glxinfo | grep -i direct
to confirm that direct rendering is enabled. It should report:

glxinfo | grep -i direct
direct rendering: Yes

The nvidia driver from the Ubuntu repos should always be your first choice. That is why they are there in the repos. Using the driver from the Ubuntu repos results in a cleaner, more easily managed system. It is similar to installing the nvidia driver "the debian way" when running Debian.
The only reason to use the driver from nvidia.com is if you absolutely must have the latest driver as soon as it comes out for some reason. Usually, this is not the case.

April 19th, 2009, 10:58 AM
i did try the one from the repos but got all the same eerors, anyway, i upgraded to Jaunty and everything was fixes. the driver was automatically installed and my resolution was automatically at what it should be. the only thing that i had to do was download a check compiz script which said that i was using the wrong desktop manager. it asked if it could change to the right one. i allowed it to and voila, my effects work - problem solved.

btw, thx everyone for the amazing help!