PDA

View Full Version : [ubuntu] Graphics drivers issue with integrated Intel chipset



Bendihossan
April 17th, 2009, 11:43 AM
Hey there,

Done a bit of Googling and forum hunting and I can't find a solution for the following issue that works with me. I'm running 8.04 on my Acer Aspire 7720 laptop and have had no serious issues to date with the exception of 8.10 being unable to detect my University's wired network. However yesterday I tried to add an external monitor to the laptop and I ended up loosing my graphics driver.

At the moment I'm running with the VESA generic video driver which works fine resolution-wise but I'm unable to use compiz effects which I rather like using for workflow (specifically working with photos). I've tried using
sudo displayconfig-gtk to configure Intel drivers but have been unable to get any working so far.

Some outputs of commands I've been using to debug this issue:


lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)


sudo 915resolution -l
Intel 800/900 Series VBIOS Hack : version 0.5.3

Chipset: 965GM
BIOS: TYPE 1
Mode Table Offset: $C0000 + $268
Mode Table Entries: 36

Mode 30 : 640x480, 8 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1440x900, 8 bits/pixel
Mode 41 : 640x480, 16 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4d : 1440x900, 16 bits/pixel
Mode 50 : 640x480, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1440x900, 32 bits/pixel


So to summarize, the two problems I need to be fixed are:

Use of an Intel specific driver for the Integrated Intel Chipset
Use of compiz desktop effects


Any help fixing this issue will be greatly appreciated. Let me know if I need to provide any other info to debug this. :)

Bendihossan
April 17th, 2009, 03:24 PM
Bump!
Done a bit more researching and thought it appropriate to post xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection


Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection
Section "Device"
Identifier "Configured Video Device"
Boardname "Intel 965"
Busid "PCI:0:2:0"
Driver "vesa"
Screen 0
Vendorname "Intel"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 640 480
Modes "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Synaptics Touchpad"
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "Intel 965"
Busid "PCI:0:2:0"
Driver "vesa"
Screen 1
Vendorname "Intel"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "device" #
Identifier "device2"
Boardname "VESA driver (generic)"
Busid "PCI:0:2:1"
Driver "vesa"
Screen 0
EndSection
Section "screen" #
Identifier "screen2"
Device "device2"
Defaultdepth 24
Monitor "monitor2"
EndSection
Section "monitor" #
Identifier "monitor2"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

Bendihossan
April 17th, 2009, 05:09 PM
Still fiddling. Now using the intel - Experimental modsetting driver but am still unable to use Compiz desktop effects. Anybody got any ideas?

I also tried X -configure but that failed to run so I ran the kernal recovery option on the GRUB loader and ran it from there and it appeared to run fine but still no progress was made. Anybody got anything on this? :(

Windsurfer619
April 17th, 2009, 07:01 PM
I had a problem like this before. If you run "compiz --replace" on a terminal, what do you see? If it is something like
"/usr/bin/compiz.real (core) - Error: Could not acquire compositing manager selection on screen 0 display ":0.0"
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0
Window manager warning: Workarounds for broken applications disabled. Some applications may not behave properly."

Then metacity has a compositing flag set in gconf.

Bendihossan
April 17th, 2009, 10:11 PM
I had a problem like this before. If you run "compiz --replace" on a terminal, what do you see? If it is something like
"/usr/bin/compiz.real (core) - Error: Could not acquire compositing manager selection on screen 0 display ":0.0"
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0
Window manager warning: Workarounds for broken applications disabled. Some applications may not behave properly."

Then metacity has a compositing flag set in gconf.

Yeah I had that too. I ended up solving this the old fashioned way with a quick back up of data and re-installing 8.04. There must be an easier way of doing it though. Hopefully this will be solved a better way sooner or later for future reference.

Windsurfer619
April 18th, 2009, 03:40 PM
There is.
Press Alt+F2 to bring up the run dialog. Type in "gconf-editor" and press enter. Navigate into Apps > Metacity > General. Uncheck "Compositing manager" and your screen will flicker. Close gconf-editor. Now you can go into Appearance and enable desktop effects :)

chronniff
April 21st, 2009, 10:24 AM
The reason you can't use compiz is because of the video card you have....the intel 965 card has been blacklisted in compiz because of a bug that has sprung up at the last minute....I too have that card, and have been testing jaunty for a while, but in the homestretch they decided to unleash the latest intel drivers, which In my humble opinion, has lead to this bug which locks up the Xserver randomly and for no good reason that anyone can figure out....the lock ups are thought to happen when x is being overloaded so they blacklisted us in compiz in an effort to protect people from these lockups, however, people are reporting that this is happening without compiz as well.....The lockups have been happening less frequently as of late though, and if your are willing to to risk locking up your system you can bypass the blackist if you create the file ~/.config/compiz/compiz-manager and in it your write: "SKIP_CHECKS=yes" without the quotes........I'm actually really disappointed with the jaunty release, not only for this terrible bug, but also because the intel graphics drivers are performing so poorly in general, obviously this is because the are essentially bleeding edge, but I shouldn't have to using bleeding edge software just to run the newest ubuntu..........As now I am ranting, I will cut myself off and say good luck to you