View Full Version : [ubuntu] Unable to mount any USB flash drives

April 17th, 2009, 02:25 AM

I just came into the world of ubuntu 8.1 on my benq laptop, and after installing it, it failed to register any USB flash drives. I installed all the upgrades, rebooted, and the USB drives worked fine, but now they've stopped working again. They don't even show up anywhere, it doesn't give me a message saying unable to mount or anything. I found a few other posts but they all rely on being able to find the drive in the first place. Any help would be awesome, keeping in mind I am a complete noob.


April 17th, 2009, 02:51 AM
Alright, I tried sticking a flash drive in again, and now it is giving me an error message that says -

DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

And then I tried it again, it took ages but worked fine, with no error message. So I unmounted, tried a different one, and it's not working. And now the original one isn't working again. Frustrating.

How do I access the bus security policy, whatever that is?

April 18th, 2009, 07:43 PM
My monitor (HP w2207) has a USB hub and IF I attach that monitor to the computer I can't use my external HD.

Try to unplug any other USB devices and attach the flash drive then.

Hope that helps you...