PDA

View Full Version : [gnome] Disabling iphone automount



n8wood
April 16th, 2009, 03:03 AM
Hi, I'm working on udev scripts that allow me to automatically sync my iphone with a VirtualBox VM that starts/shuts down when I connect/disconnect my phone. So far the scripts seems to be working, but I am getting error messages that makes me think GNOME is trying to automount the device:

"Unable to mount Apple, Inc. iPhone
Error initializing camera: -60 : Could not lock the device"

I looked into gnome-volume-manager options in gconf, and looked at the Removable Devices preferences, neither seemed to help.

Any ideas where I can look to stop this from automounting?

n8wood
April 16th, 2009, 03:54 AM
I disabled automount entirely in Nautilus by using gconf-editor and unchecking app > nautilus > preferences > media_automount.

Not a perfect solution, but I can still many mount stuff in Nautilus.

d0b33
August 7th, 2009, 11:36 AM
I get the same error:
"Unable to mount Apple, Inc. iPhone"

This happened after trying iFuse, before iFuse I never got this message.

Uninstalling iFuse did not solved the problem

Help would be appreciated... :(

lesta
November 1st, 2009, 04:47 PM
I had the same problem! You have to uninstall some of the the iFuse dependencies: libusbmux, libiphone, libplist. I'm pretty sure that the problem is caused by libusbmux0 and nautilus usb automount conflict.

You can find some useful information about iphone/ipod syncing from this blog: http://marcansoft.com/blog/


I get the same error:
"Unable to mount Apple, Inc. iPhone"

This happened after trying iFuse, before iFuse I never got this message.

Uninstalling iFuse did not solved the problem

Help would be appreciated... :(