View Full Version : [all variants] [compiz] 'initiate window picker' -> windows don't stay

April 14th, 2009, 06:17 PM
Hey there,
I have a problem with the compiz 'Scale' plug in.
When I activate the plug in ('Initiate Window Picker') by moving the mouse to a screen corner, everything works fine. My windows are scaled down, arranged on the screen, and stay there so I can pick a window.
However, when I use a keyboard key to initiate the window picker, the windows stay downscaled only as long as I hold the key. Even worth, when I hover over a window while holding the key, the windows swap positions.
Is there a way to make the window picker work with a keyboard key the same way it works with a screen corner?

April 14th, 2009, 08:34 PM
I've had exactly the same issue. in 8.10 I found no solution. In 9.04, I've found an option in ccsm, the compiz settings manager, under the menu for scale (the item that makes it do the expose like switcher), that says "toggle scale mode on key or mouse". Checked that box, all was well.

April 14th, 2009, 08:52 PM
I'm still running 8.10. But now I really look forward to the official release of 9 next week.
Thanks for the tip!

April 14th, 2009, 08:57 PM
You bet, and I understand your frustration, I've got a post in here with word for word almost the same thing about 2 months ago- and no one had a solution for me, except telling me to just use the mouse.

I just used other window pickers since I prefer keyboard shortcuts every time. There are some neat ones in 8.10, and they do seem to work right, so give em a shot - you may like them too.

I changed to 9.04 just to find out how its gunna be, and was glad that lil bug got fixed.

Take care, and enjoy!

November 20th, 2009, 12:36 AM
At my Compiz 9.10 I also have something similar, and I don't think it will be different in any Ubuntu version.

If I setup, let's say, ALT+SHIFT+key it will stay up only while I hold ALT+SHIFT. But if I set up just F10, for instance, it will toggle up.

There are also two options "Toggle Scale Mode" to do just that even with modifier keys such as ALT or CTRL.

On my mac OS I have no such option to toggle or not... It's always toggle. I love linux for being able to customize anything easily enough! But, granted, expose is still way more pretty. :P