View Full Version : [ubuntu] error cant read superblock

April 8th, 2009, 03:25 AM
I am a somewhat new ubuntu user and I had an external hard drive on a windows pc that just recently has stopped working. There are important files (that my dad has refused to back up) on it. First I tried plugging the dive into my ubuntu pc, but i got the error mount: /dev/sdc1: can't read superblock. I thought the problem may have been the external enclosure or usb adapter so I opened the enclosure. Inside I found a western digital IDE drive. I plugged this drive into my ubuntu pc and turned it on. I clicked the mount disc applet on my toolbar and I got the same error :mad:. What does that error mean and is there any way to get my data back :-(:icon_frown:

Sam Lars
April 9th, 2009, 04:19 PM
That means there's some problem with the filesystem or possibly with the drive itself.
You should try a filesystem check on it... maybe through the Partition Editor (gparted).

April 12th, 2009, 12:24 AM
Well I tried that but I got the same error and was still unable to recover my files :( What now? Is my data lost forever?

Sam Lars
April 12th, 2009, 08:48 PM
If you're getting that error and a drive check doesn't fix it, then I don't see much hope for it.
There are companies that do data recovery, if it's worth a bit of money to you.