PDA

View Full Version : [ubuntu] Xconf and nvidia settings



Feelin_froggy8877
April 7th, 2009, 03:20 PM
I am having a problem with saving nvidia settings to xconf..I have to reset my display every time i reboot, as ubuntu's screen res only allows 800 by 600, after saving settings (ran nvidia conf from term as su to preferred display..1024 768 at 60 refresh rate all my 3d app windows are white. Apps like cairo-dock and applets...etc. my display adpter is nvidia gforce2 mx 100/200, 240 ghz p4. Im sure there is a way to manually edit xconf,, but Im not quite at that level yet, Any other info that might be needed please let me know. Thanx in advance.

Zeedok
April 8th, 2009, 09:26 AM
I think I have had similar problems in the past. Sorry I can't help - my only suggestion would be to run the nvidia-settings as sudo, but it sounds like you've already done that.

At least I've bumped you up to the top of the list . . . maybe someone new will have a suggestion.

NESFreak
April 8th, 2009, 09:37 AM
which version of ubuntu are you running?

http://www.ubuntu.com/getubuntu/releasenotes/810

nVidia "legacy" video support

The 71 and 96 series of proprietary nVidia drivers, as provided by the nvidia-glx-legacy and nvidia-glx packages in Ubuntu 8.04 LTS, are not compatible with the X.Org included in Ubuntu 8.10. Users with the nVidia TNT, TNT2, TNT Ultra, GeForce, GeForce2, GeForce3, and GeForce4 chipsets are affected and will be transitioned on upgrade to the free nv driver instead. This driver does not support 3D acceleration.

Users of other nVidia chipsets that are supported by the 173 or 177 driver series will be transitioned to the nvidia-glx-173 or nvidia-glx-177 package instead. However, unlike drivers 96 and 71, drivers 173 and 177 are only compatible with CPUs that support SSE (e.g. Intel Pentium III, AMD Athlon XP or higher). Systems with older CPUs will also be transitioned to the nv driver on upgrade.

and yeah it sucks

loomsen
April 8th, 2009, 09:47 AM
Yes, well, actually, NO! Why don't make this a little more common.

Make your changes with nvidia-settings, when done, choose to save settings to
~/.nvidiarc
(default)

Now save your screen settings too, but NOT to
/etc/X11/xorg.conf

Instead, chose a folder where you have write permissions. For instance
$HOME/backup/xorg.conf

Create the folder if it doesn't exit, or save the file to your desktop or where ever you want to.

Then, open up a terminal, and follow me.....(I assume our path to be /home/<user> directly after opening up a terminal)
First, let's back up your existing one, then replace it with your newly created:


sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup && sudo cp backup/xorg.conf /etc/X11/xorg.conf

Close the terminal, respawn your session (if you don't know how to do this from a shell simply reboot)

And you're done.

DON'T write/create/change/save a file as root to your home directory. The way provided above you only copy a file to some-path, plus you don't have to run a GUI with admin privileges.

Oh, btw, to load your settings at startup (digital vibrance, anti aliasing, textures, antisoptric filter) create a new starter (preferences->startup applications (or sessions if you ain't running jaunty) and issue

nvidia-settings -l
as command.


(IF YOU CHOSE TO DO, USE gksu instead of sudo, which is actually the command to gain root privileges for graphical applications.

But I'd suggest doing what I wrote above.

Feelin_froggy8877
April 8th, 2009, 06:11 PM
I am running Intrepid 8.10 Kernel Linux 2.6.27.11
Nvidia driver version 96.43.09

I could be wrong...but it seems to me loomsen's advice is pretty much doing the same as running nvidia settings as su in a term witch would give me the same result.But I'll give it a shot.The thing I didnt do was save a backup of my original xorg.cong before I saved my new nvidia settings. I really played hell getting everything back right.

Feelin_froggy8877
April 8th, 2009, 06:27 PM
Got the same result...man what a difference it makes saving a backup...haha any way, Is there no workoround for this incompatibility?

Feelin_froggy8877
April 8th, 2009, 07:13 PM
here it xconf generated by nvidia...

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Mon Nov 3 08:46:46 UTC 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "HP MX50"
HorizSync 30.0 - 54.0
VertRefresh 47.0 - 100.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce2 MX 100/200"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1024x768_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection


And here is the conf generated by dexconf....



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection


Hope this helps.

PreviousN
April 8th, 2009, 07:59 PM
Try envy-ng, it automagically configures everything. I haven't had to mess with xorg for so long that I've pretty much forgotten how! http://albertomilone.com/nvidia_scripts1.html