View Full Version : [ubuntu] Networking problem. Lost my LAN.

April 7th, 2009, 09:25 AM
Hi all!

I'm new to this forum and to Ubuntu.
I installed Ubuntu 8.10 on a machine I intend to use as a server in a small network (LAN). I'm using a Tenda router (model W54 1R) with the Ubuntu machine cabled to port 4, the other machine (Vista) is on wireless. Also I installed Subversion (SVN), MySql, Tomcat.6 and Samba. The server has a fixed IP-address ( and everybody else will be given a dynamic IP address. Everything installed in a matter of hours and everything ran smoothly for a week or so until yesterday when I lost the network.

Both machines are still able to see the internet and I can ping one machine from the other. The Network display (Start->Network) in Vista shows only my local PC and the Places->Network display in Ubunto show an entity called "Windows Network". The server name (EHSERVER) is missing! When I double click the "Windows Network" icon, I get an error messages "Unable to mount location".

I can SSH (using putty) from Vista to Ubuntu if I give the IP address. Name resolution no longer works. I'm not able to access any of the services running under Ubuntu from the Windows machine. times out from Windows while it works fine on the server. Also there is no contact to my Subversion repository on port 3690 or to mysql on port 3306.

Anybody have an idea what might be wrong?

Kind regards

April 7th, 2009, 09:29 AM
post the output of


cat /etc/network/interfaces

cat /etc/hosts

cat /etc/resolv.conf

April 7th, 2009, 09:40 AM
Thank you Hyper for dealing with my problem.
Here is the results of your suggestions:


eth0 Link encap:Ethernet HWaddr 00:0f:ea:f3:3e:49
inet addr: Bcast: Mask:
inet6 addr: fe80::20f:eaff:fef3:3e49/64 Scope:Link
RX packets:4446 errors:0 dropped:0 overruns:0 frame:0
TX packets:2626 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2049513 (2.0 MB) TX bytes:340563 (340.5 KB)
Interrupt:23 Base address:0xa000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:393406 errors:0 dropped:0 overruns:0 frame:0
TX packets:393406 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:19694829 (19.6 MB) TX bytes:19694829 (19.6 MB)

cat /etc/network/interfaces
auto lo
iface lo inet loopback

cat /etc/hosts localhost ehserver

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

cat /etc/resolv.conf
# Generated by NetworkManager

April 7th, 2009, 09:54 AM
looks fine to me

clear the dns cache in your windows box:

ipconfig /flushdns
ipconfig /flush

not sure which one it is.

April 7th, 2009, 10:14 AM
Problem with Vista.

C:\>ipconfig /flushdns
This action requires administrator rights.

Even when I'm logged in as an administrator. Microsoft!

Don't you think I have to change the settings in /etc/hosts like this? localhost ehserver

April 7th, 2009, 10:20 AM
well, a simple and dirty trick is to add the IP of the server into your windows hosts file.

No clue where it is in VISTa but in xp it was c:\windows\system32\drivers\etc

just add there the


and you're set.

April 7th, 2009, 10:44 AM
I changed the c:\windows\system32\drivers\etc\hosts file to include my Ubunto server. Now I can use name resolution with SSH, but I'm still not able to access my services or to connect my Samba network drives and printer.

It worries me that the familiar graphic

<Work-station> ---> <Network> ---> <Other machines on the network>
does not show up, neither at the Windows side, nor at the Ubuntu side.

April 7th, 2009, 12:25 PM
I hate samba... but Stormbringer made a nice howto in the tutorials section. You might want to have a look at that.

April 7th, 2009, 03:08 PM
I hate samba... but Stormbringer made a nice howto in the tutorials section. You might want to have a look at that.:lolflag:

Instead of Samba, can you suggest something better?

Quite frankly, I don't think this is a Samba problem. I think I should be able to access my services, Tomcat, MySql and Subversion without Samba. If I have understood correctly, Samba only creates Windows shares that can be mounted from a Windows environment.

As a desperate measure, I have disabelled the firewall on the Windows maschine, but that did not change the situation a bit. I understand, Ubuntu does not have a firewall, but soemething called iptables instead.

April 8th, 2009, 09:20 AM

I solved the problem.

sudo lokkit --medium
This reduces the level of protection the iptables give to medium, effectivly opening up for access to the Ubunto server from the LAN.

How the protection level was set to high in the first place, I have no idea.

Thanks for the help and for the discussion.


April 8th, 2009, 01:49 PM
why do people have the urge to mess around with iptables without knowing what they do?