View Full Version : [gnome] Error: /home/user DOES NOT EXIST on SDHC after Easy Peasy login

April 6th, 2009, 05:42 PM
Can someone help me on this one?

I've installed ubuntu's easy peasy on my 901. GNOME.

mounted as such:
sda ext2 / on the 4GB SSD
sdb ext3 /usr and /tmp on the 16GB SSD
sdc ext3 /home on a Kingston 8GB SDHC class 6
not using a swap

was running like a charm for over a week, when suddenly today on boot up after i login, i get the ERROR /home/username DOES NOT EXIST. then asks me to create it in the /root.
every session i try hangs before my desktop appears. except TERMINAL, which i can access.

i can see the USB FLASH entry in the BIOS.
i'm using a grub splashimage.

what have i done wrong? should i partition differently? how can i get /home working again on the SDHC? (i don't care about lossing data on the SDHC, i just want to avoid a fresh installation)

i've seen other post with similar issues .. but not exactly as i have.


April 6th, 2009, 05:52 PM
Does the 8GB drive get mounted when you boot your machine?

sudo fdisk -l
sudo blkid
cat /etc/fstab
df -h

April 6th, 2009, 05:57 PM
would i see if the drive gets mounted by hitting ESC at the grub?

April 6th, 2009, 06:23 PM
Nope. You have to wait for it to finish booting before you can view your harddrives.

April 6th, 2009, 07:08 PM
could catch the drive to see if was mounted, scrolling to fast. couldnt pause. im quite new to linux. sorry.

but what i saw in terminal

sudo fdisk -l sdc- my SD card was in the list
sudo blkid also listed
cat /etc/fstab not listed
df -h not listed

btw: taurus thanks for your time

April 6th, 2009, 07:18 PM
If it is not in /etc/fstab, then you need to add an entry in there for that 8GB drive, mounting to /home. The entry in /etc/fstab for that drive, using UUID, would look something like

UUID=abcd1234efgh5678 /home ext3 relatime 0 2
Of course, you need to replace the UUID with the right one for that drive.

Save it and reboot.

April 6th, 2009, 07:36 PM
how do i edit the fstab? have tried before .. couldnt do it from terminal.
i have the uuid of the SD.
is this something like making the SD persistant?

April 6th, 2009, 07:48 PM
sudo nano -Bw /etc/fstab
Once you're done editing, save it and exit with <Ctrl>x and y for the question.

April 6th, 2009, 08:16 PM
cant thank you more ... adding it to the fstab worked.
there are many other methods others have posted .. yours was short and simple.
does this make it a permanent member ... like persistant?
thanks again taurus!

April 6th, 2009, 08:22 PM
Yes, it's permanent unless you remove it from /etc/fstab or your USB is acting up.