PDA

View Full Version : [ubuntu] Vuze sucks how do I install Azureus?



Captain_Glen
April 6th, 2009, 03:41 AM
Hi,

On Hardy Heron I had Azureus. I have recently upgraded to Intrepid Ibex. When I run:


sudo apt-get install azureus

It installs Vuze. Vuze sucks how do I find an old version of Azureus?

Hospadar
April 6th, 2009, 05:04 AM
You could get one from the azureus website, but I hardly see the need. There are a plethora of great torrent clients for linux.

Transmission comes installed by default, I use it on my server box and love it, you could also try deluge, ktorrent, and there are more if you search around.

For normal desktop use I really prefer deluge, but I like transmission's web client a little better (although deluge has a very excellent web client)

asmoore82
April 6th, 2009, 05:05 AM
Azureus is now Vuze: http://azureus.sourceforge.net/

kdreimiller
April 6th, 2009, 05:06 AM
i use deluge. a few more bells and whistles than transmission. and vuze (azureus) was always trying to update itself without ever updating and drove me nuts.

lovinglinux
April 6th, 2009, 06:10 AM
You can turn off all that Vuze stuff, by choosing the basic interface. I don't remember exactly how to do this, but it shouldn't be hard to find this option. It will look exactly like Azureus.

I used Azureus for a long time, but since I installed Deluge I never looked back.

Captain_Glen
April 7th, 2009, 01:21 AM
Can you schedule Deluge. I can't figure out how.

lovinglinux
April 7th, 2009, 03:01 AM
Can you schedule Deluge. I can't figure out how.

The old version (0.5.x) has a scheduler plugin, but I'm afraid the new one (1.x.x) doesn't. Anyways, you can download 0.5.x series at http://download.deluge-torrent.org/archive/ubuntu/

I was using version 0.5.8.9 until 2 days ago and it worked like a charm. Version 0.5.9.4 is the last version of the 0.5 series.

madverb
May 8th, 2009, 04:02 PM
Even though this thread is a bit old I thought I would give you an update. Although the scheduler hasn't been ported to version 1 of Deluge you can schedule download periods another way.

sudo apt-get install gnome-schedule deluge-console
And then follow this http://dev.deluge-torrent.org/wiki/UserGuide/Scheduling

powel212
May 8th, 2009, 04:29 PM
Ktorrent is the answer

It does everything. An, it's way lighter than Vuze.

P.

Chemical Imbalance
May 8th, 2009, 04:34 PM
Deluge and Ktorrent are my favorites.
They are both lightweight and have DHT.

PsySc0rpi0n
May 13th, 2009, 10:25 PM
I would also like to install Azureus aka Vuze...

I have Vuze 3.1.1.0 and everytime i start Vuze it asks for an update that i downoad but i can't instal it... It's a JAR file (Azureus4203-B18.jar). Then i download commons-cli.jar and log4j.jar and placed all 3 files in the same folder.

Than i started the console, entered in the folder and performed the following command:

java -jar Azureus4203-B18.jar --ui=console

The process starts to run but i guess that it never comes to an end because the console should finish the process and show the folder path and it doesen't...

My console after the command satys like this for ever



psysc0rpi0n@psysc0rpi0n-desktop:~/Documentos$ java -jar Azureus4203-B18.jar --ui=console
file:/home/psysc0rpi0n/Documentos/Azureus4203-B18.jar ; file:/home/psysc0rpi0n/Documentos/

Core Start Completed
ConsoleInput: initializing...
Attempting to load aliases from: /home/psysc0rpi0n/.azureus/console.aliases.properties
ConsoleInput: initialized OK
ConsoleInput: starting...
ConsoleInput: started OK
Running Vuze 4.2.0.3_B18...
Using configuration settings from:
/home/psysc0rpi0n/.azureus/
> -----
Available console commands (use help <command> for more details):

[] xml [#] hack [a] add [c] check [q] queue [r] remove
[s] start [h] stop [] host [] publish [] forcestart [tl] tlog
[l] log [m] move [] share [+] set [sh] show [u] ui [] logout
[] quit [?] help [] alias [] prio [] plugin
> -----
DEBUG::Wed May 13 22:34:16 WEST 2009::org.gudy.azureus2.core3.internat.IntegratedR esourceBundle::handleGetObject::265:
Failed to load message bundle scratch file
ResourceBundle::getObject::396,ResourceBundle::get String::362,MessageText::getResourceBundleString:: 318,MessageText::getString::285,TrackerStatus::upd ateSingleHash::256,TrackerStatus::updateSingleHash ::201,TrackerChecker::runScrapes::323,TrackerCheck er::access$000::37,TrackerChecker$1::runSupport::6 9,AEThread::run::74
java.io.FileNotFoundException: /home/psysc0rpi0n/.azureus/tmp/AZU9181322569686801726.tmp (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:137)
at org.gudy.azureus2.core3.internat.IntegratedResourc eBundle.loadMessages(IntegratedResourceBundle.java :466)
at org.gudy.azureus2.core3.internat.IntegratedResourc eBundle.handleGetObject(IntegratedResourceBundle.j ava:265)
at java.util.ResourceBundle.getObject(ResourceBundle. java:396)
at java.util.ResourceBundle.getString(ResourceBundle. java:362)
at org.gudy.azureus2.core3.internat.MessageText.getRe sourceBundleString(MessageText.java:318)
at org.gudy.azureus2.core3.internat.MessageText.getSt ring(MessageText.java:285)
at org.gudy.azureus2.core3.tracker.client.impl.bt.Tra ckerStatus.updateSingleHash(TrackerStatus.java:256 )
at org.gudy.azureus2.core3.tracker.client.impl.bt.Tra ckerStatus.updateSingleHash(TrackerStatus.java:201 )
at org.gudy.azureus2.core3.tracker.client.impl.bt.Tra ckerChecker.runScrapes(TrackerChecker.java:323)
at org.gudy.azureus2.core3.tracker.client.impl.bt.Tra ckerChecker.access$000(TrackerChecker.java:37)
at org.gudy.azureus2.core3.tracker.client.impl.bt.Tra ckerChecker$1.runSupport(TrackerChecker.java:69)
at org.gudy.azureus2.core3.util.AEThread.run(AEThread .java:74)




"DEBUG::Wed May 13 22:34:16 WEST 2009::org.gudy.azureus2.core3.internat.IntegratedR esourceBundle::handleGetObject::265:
Failed to load message bundle scratch file"

Is that error normal?


And when i try to close the console it says to me that there is a process running and if i close the console the process will bi killed...

MontelEdwards
May 13th, 2009, 10:35 PM
OK. If you just download the file from the Vuze website... and double click on Vuze.. it works fine. No terminal required. And to the OP: Vuze is the new name.

PsySc0rpi0n
May 14th, 2009, 07:15 AM
Hello...

Well i downloaded Vuze from its website and it was a tar.bz2 file. I extracted it into a folder but when i ask to "Open-Execute in Console (or just Execute)" the Azureus file that is in the extraced folder, nothing happens.

How can i solve this???

Edit;

Switched to Deluge... Looks a lot like Windows uTorrent and is simple to use...

jjosotoro
June 2nd, 2009, 09:25 PM
ok your problem is something a lot of people is passing trougth whit ubuntu jaunty, the way i solved it was very simple and actually gave me acces to other aplications i use a lot; what i did was adding the getdeb repository to mi list

echo "deb http://getdeb.masio.com.mx/ jaunty/" | sudo tee -a /etc/apt/sources.list.d/getdeb.list && sudo apt-get update

now if that gives an gpg error like this:

W: GPG error: http://getdeb.masio.com.mx/ jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B152F042D246C25D

you must use the following command in the terminal:

gpg --keyserver hkp://subkeys.pgp.net --recv-keys "XXXXXXXXXX"
sudo gpg --export --armor "XXXXXXXXXX" | sudo apt-key add -
sudo apt-get update

replacing the "XXXXXXXXXX" whit the number that appears in the message ex: B152F042D246C25D

$sudo apt-get update

just to check about the gpg error (it shouldnt appear anymore)

$sudo apt-get install vuze

this will install the version of vuze that is on getdeb (4.2.0.2) whit all dependencies, or you can install it using synaptics.

$sudo chmod -R 777 /usr/share/vuze

this will let vuze to do any upgrade

trooperchix
June 29th, 2009, 12:25 AM
jjosotoro... you rock. all the millions of ways I've been trying to get vuze to work on jaunty... this worked. it is unweildly, but I like the search function integrated. Thanks!!

lulu135
October 6th, 2009, 03:03 AM
I think for certain applications, especially apps with built-in update features, it's easier to avoid using the package manager and just download the offical release and untar it in a directory somewhere.
Then you can just create a shortcut to the main binary or run it from the command line.

The problem with installing it as root using apt-get is that the self-update never works and you have to wait for your distro to create a new package before you can upgrade. If you use the Vuze's own release then you can always have the latest version whenever you want, and if you want to uninstall it's as easy as rm -rf vuze/