PDA

View Full Version : [ubuntu] How to handle this Nvidia error message????



lentomies
April 5th, 2009, 06:44 PM
Hello,

I just installed EnvyNG and now have the NVIDIA X server settings found under System---> Administration.

But when I open this it reports an error message which I have no idea as to how to handle. Please look at the attached picture.

Maybe someone can tell me what to do???

Currently, it appears that my 8.04 already knows I have a Nvidia graphics card as it is found under restricted drivers. I'd like to note that this appeared before I installed EnyyNG. I attached a pic of this too.

Thanks!

nandemonai
April 6th, 2009, 08:37 AM
Hello,

I just installed EnvyNG and now have the NVIDIA X server settings found under System---> Administration.

But when I open this it reports an error message which I have no idea as to how to handle. Please look at the attached picture.

Maybe someone can tell me what to do???

Currently, it appears that my 8.04 already knows I have a Nvidia graphics card as it is found under restricted drivers. I'd like to note that this appeared before I installed EnyyNG. I attached a pic of this too.

Thanks!

I *think* it has to do with the fact you're using the legacy drivers. What card?

freak42
April 6th, 2009, 10:04 AM
try uninstalling-reinstalling the restricted driver.. it might just reconfigure your xorg

Sealbhach
April 6th, 2009, 10:50 AM
If those steps don't work, try removing it and reinstalling it via Synaptic. The package is called nvidia-glx.

If that doesn't work, then do this:

Press Ctrl+Alt+F1
Ths should give you a login screen. Login.
Type


sudo /etc/init.d/gdm stop


nvidia-xconfig



sudo /etc/init.d/gdm start




.

lentomies
April 6th, 2009, 02:33 PM
Thanks Everyone!

I followed all the instructions offered precisely And still I get the same error message.

I got no clue why this is happening.

Any suggestions.

Kareeser
April 6th, 2009, 02:36 PM
How did you uninstall/reinstall your drivers? Through EnvyNG?

lentomies
April 6th, 2009, 02:41 PM
No. I used the instructions others provided found above ^ ...

philinux
April 6th, 2009, 02:48 PM
Have you rebooted?

lentomies
April 6th, 2009, 02:51 PM
Sure did.

Sealbhach
April 6th, 2009, 03:54 PM
I think this EnvyNG must be stopping the driver from being recognised. Get rid of the envy and reinstall the nvidia-glx from Synaptic..


.

suomalainen
April 6th, 2009, 05:02 PM
I did that already. Envy was already wiped out.

freak42
April 6th, 2009, 05:41 PM
can you post the output of your /etc/X11/xorg.conf file here?

lentomies
April 6th, 2009, 05:50 PM
Here You go........

Please note my monitor is LG and I need 1440X900. Thanks

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "UseEdidFreqs" "True"
Option "AllowGLXWithComposite" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection

oldos2er
April 6th, 2009, 05:55 PM
Are you running the Nvidia settings program as root?

lentomies
April 6th, 2009, 06:19 PM
I don't know? Am I? How do you do that????

Thanks

Ann

oldos2er
April 7th, 2009, 01:49 AM
gksu nvidia-settings

lentomies
April 7th, 2009, 02:15 AM
oldos2er,

I ran the command you asked me to run.

The attached pic say's it all....

Anyone else have any ideas?????????????

oldos2er
April 7th, 2009, 02:34 AM
Have you tried booting into recovery mode and running 'xfix'?

lentomies
April 7th, 2009, 01:19 PM
Xfix? Is something broken? if so what is it?