PDA

View Full Version : [ubuntu] xorg.conf blues



Toshubu
April 5th, 2009, 09:03 AM
Hi all, good to be here. Trying to get my xorg.conf file written correctly. Got Gutsy installed and have a command line. It looks like all the files are there. Just can't get the display to work. Have spent hours on it. It's on an older laptop (Toshiba Satellite 1415) that still works good. Just wanted to get broken XP off of it. Could someone post a working xorg.conf (nvidia GeForce 4 420 Go video card). I know my way around Linux pretty good; but just am not getting anywhere. Or, if someone could point out tutorial(s) for me to look at. Been working on it for several hours, and sure would appreciate any help that's out there.

zigga15
April 5th, 2009, 09:10 AM
It would easier if I could see the xorg.conf file.

Here is some examples as a rough guide:

http://ubuntuforums.org/archive/index.php/t-340890.html

~ Dan

Toshubu
April 5th, 2009, 10:49 AM
Thanx Dan. Turns out I was missing a bunch of gdm stuff. I think I'm fairly close to getting it going now...I don't think I have the right PCI bus numbers. I'll have to study your the xorg.conf in your link. Or, it could be a resolution thing-it seems to be trying to find a resolution that is right. But it keeps coming back to the command line. Gotta give it a rest for the night. I'll try to post my xorg.conf, later. I did get a real nice login splash screen. Thanks again.

wpshooter
April 5th, 2009, 02:22 PM
Thanx Dan. Turns out I was missing a bunch of gdm stuff. I think I'm fairly close to getting it going now...I don't think I have the right PCI bus numbers. I'll have to study your the xorg.conf in your link. Or, it could be a resolution thing-it seems to be trying to find a resolution that is right. But it keeps coming back to the command line. Gotta give it a rest for the night. I'll try to post my xorg.conf, later. I did get a real nice login splash screen. Thanks again.

First have you tried installing using the safe graphics mode parameter and if that does not work, then try doing the installation from the ALTERNATE (text based) CD version of Ubuntu instead of from the live CD version.

norwoods
April 5th, 2009, 03:28 PM
if you rename xorg.conf and run sudo nvidia-xconfig, you will get an autogenerated xorg.conf.

Toshubu
April 5th, 2009, 11:22 PM
Thanks everyone. Got it working finally. I just didn't have all of the gdm files I needed. Now working on some other little problems; but will start a new thread, if need be. Thanks again.