PDA

View Full Version : Wierd bug on my website, possible PHP problem?



gjoellee
April 4th, 2009, 04:35 PM
Hi there!

I just updated my website www.kshoster.net with a new template. It looks great, but of some reason it doe snot work great...

Every page looks the same as the home page. See yourself....try to go to, ie. The about page. It looks the same!

What makes it even more weird is that it works great on localhost! So if it works in localhost, why doesn't it work on the internet?

I am not sure which files you need to look at,but this might help you...?


<div id="content-in">
<?php
if(!isset($c)) {
$c = "main";
}

$shitzang = "inc/$c.php";

if(!file_exists($shitzang)) {
$shitzang = "inc/404.php";
}

include($shitzang);
?>
</div>

s.fox
April 4th, 2009, 05:01 PM
Hi,

Your links direct the user to the same page but you are passing a variable "c".

Where are you reading in the variable "c" on your index.php page? I don't see it in your code posted above.

Odd that it works on local host though...

gjoellee
April 4th, 2009, 05:18 PM
The code above adds another file called "main.php" to the place where the code is (the code above) in the index.php file.

gjoellee
April 4th, 2009, 05:20 PM
Here is an attachment on my index.php file (but because the forums don't allow .php it is in .txt)

gjoellee
April 4th, 2009, 06:31 PM
It works! Don't know how...!

simz
April 4th, 2009, 06:33 PM
Hi!

I have uploaded a fix.

The problem was that $c was not defined properly. I also fixed the tux gallery.

- simz