View Full Version : [ubuntu] screenlets autorun?

April 2nd, 2009, 09:57 PM
Hi, i just installed scrennlets and i put some of them in my desktop, then i restart my pc. The screenlets daemon was running, but my screenlets wasnt there, ive waited for some minutes and nothing, so i have to start them manually. Is this normal? or am i doing something wrong?

April 3rd, 2009, 12:10 AM
Did you check the screen lets daemon in your start up?
apps.menu session start up and see if it's checked if not
check it then it should start the next time you reboot.

April 3rd, 2009, 02:30 AM
If the daemon (Screenlets Manager icon?) is running but the screenlets aren't, check in the Screenlets Manager that you have ticked the Auto start on login option for each of the screenlets you selected - it is an individual, not global, setting.

Could be you set it for one which you subsequently removed but forgot to do it for the rest.

April 3rd, 2009, 05:14 AM
Oh check to see if when you put your screenlets on the desktop
your check run at start up of go to start up and put a check by it there

April 3rd, 2009, 05:40 PM
I can see the daemon running but the desklets arent there! I looked for that option of autostart but i couldnt find it! In the properties of each one i can see an option called

"Trated like a widget"

Maybe is that?

April 3rd, 2009, 05:47 PM
okay, i found that option, now they autostart! thanx 4 the help!

April 3rd, 2009, 06:04 PM
Go to Applications>Accessories>Screenlets, you'll see this window, just select the screenlet(s) you want and check "Auto Start on Login"


EDIT: sorry, I was a little bit late...

February 15th, 2010, 03:44 PM
Oddly enough, I have the Screenlets daemon set to start in Preferences -> Startup Applications, and each of my desired screenlets have "Autostart on Login" ticked, but none of them load on startup.

If I open the Screenlets Manager, I see none of them have "Start/Stop" ticked. If I manually start them, then I see multiple instances. As though an instance was already running, but they didn't show up until then.

I have them running in a widgets layer, and that is always running, they're just not there.

Any ideas?

February 16th, 2010, 05:00 AM
I have them running in a widgets layer, and that is always running, they're just not there.
I know this might sound like an obvious question so please excuse me but are you actually showing the widget layer? I have some of my screenlets on the widget layer which means they are hidden until I show the layer with F9.

Have you also tried setting them as non-widget and seeing if they show at login?

February 16th, 2010, 02:11 PM
I kept searching around in other threads and there were two things that fixed my problem.

To fix the issue of multiple screenlets being opened at a time

I navigated to home/[username]/.config/Screenlets and went into the individual folders for all of my desired Screenlets. What I found is that those running more than one instance had more than one .ini file. So I just deleted all of those files so I could start over.

To fix not starting at login

I navigated over to usr/share/Screenlets and opened up permissions on that folder. Once that was done, I went to the Screenlets Manager and stopped and started again all my desired screenlets.

I'm not sure why this would be an issue in the first place. It would be great if these things didn't trip up such a great program.

Regardless, I'm very happy now with my Screenlets and Widget layer! I've also set up my Desktop corners so I can quickly access them with a mouse swipe. Ahhhhhhhhhhh..........