View Full Version : [ubuntu] When visual effects on, cannot see menu headings in open office.

April 2nd, 2009, 09:52 PM
Hi, I've searched but not been able to find a solution to my problem.

I have an Nvidia graphics card, and the proprietary drivers for it, and I assume that it is causing the problem.

When I go to Appearence and change Visual Effects from off to Normal or Extra, when I open an Open Office program, the words are missing from the clickable buttons, like the menu tabs at the top (File, Edit, View etc.) like you can see in the screenshots attached.

They are there for a split second when the programs start, but then disappear, and if I hover the mouse over the button they reappear for another split second but then disappear again.

But other programs like Evolution or Gedit work fine with no missing words.

Any help will be appreciated, thanks.

April 3rd, 2009, 11:39 AM
Anybody know anything to help?

April 3rd, 2009, 12:52 PM
It is a nvidia bug if i am not wrong.There are huge amount of topics about this.Please search the forums.

April 3rd, 2009, 03:02 PM
Yep, with a little harder searching I found a solution.

Many fixes found on:


April 3rd, 2009, 06:33 PM
To the poster who simply replied "Just go search", that's not helpful. It took me a little while to find even this thread with searching, so it's better if these specific concerns can be addressed in the thread.

In one of the links above I found this advice, which worked for OOo:

Same here. Running Ubuntu 8.10 Gnome / Compiz. I found a way to make the menus appear. Set effects to none, open any OpenOffice application (I opened Spreadsheet). Go to Tools->Options. Expand OpenOffice.org and select "View" and de-select Screen Font Antialiasing. Then activate your effects again; the fonts stay.

I still have the same problem with WINE. But at least for now I can keep my effects on (and, hence, run Cairo-Dock normally) and still have OOo work.

April 3rd, 2009, 10:47 PM
ffahog I found a solution for WINE aswell.

It's on here: http://www.nvnews.net/vbulletin/showthread.php?t=122695

But first your method for getting the fonts to work isn't the best because they will be a bit fuzzy.
I reccomend reactivating antialiasing and instead following the method on that link, which is:

from terminal.
1. Update the xorg.conf

sudo gedit /etc/X11/xorg.conf

Make it look like this:

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x800" "1024x768" "800x600" "640x480"

Section "Extensions"
Option "Composite" "Enabled"

My own one actually looks like:
Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"

Section "Module"
Load "glx"

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "RenderAccel" "0"

Section "Extensions"
Option "Composite" "Enabled"

You can manually add more resolutions to this line:
Modes "1600x1200" "1280x800" "1024x768" "800x600" "640x480"

2. Go to System > Preferences > Appearence > Fonts
Select Subpixel

that last subpixel bit I was able to disable and the fonts still worked.

but to make WINE work:

Type in terminal:

sudo gedit /home/settings.txt

and paste in the following text then save

[HKEY_CURRENT_USER\Software\Wine\X11 Driver]

Go to a terminal window and write:

regedit settings.txt

Remember to reboot your system after installing the driver.

Hope this works for you too

PS: There will be a driver update that fixes the problem itself, but for now, this seems to be working just fine.