PDA

View Full Version : Bloquejar el Touchpad



jinglada
March 29th, 2009, 11:29 PM
En el Packard Bell, EASYNOTE MT85-M-005SP (http://support.packardbell.com/es/item/?m=home&pn=PC18E01904), el teclat inclou sota la barra espaiadora hi ha un botó que anomena "Bloquear Touchpad (http://support.packardbell.com/es/item/index.php?i=instr_ic_touchpadlock_yamit_steele&ppn=PC18E01904)". I afegeix que: "El botón Bloquear Touchpad se encarga de activar o desactivar el touchpad para evitar los movimientos de cursor no deseados que se pueden producir a la hora de utilizar el teclado. Se trata de la opción más útil en caso de que tenga conectado un ratón al ordenador. El botón se enciende cuando el touchpad está bloqueado."

Qué hauria de fer per a activar el Bloquear Touchpad?

PatrickVogeli
March 30th, 2009, 01:22 PM
Et dic el mateix que a l'altre fil, la solucio comença de manera igual:



prem el boto varies vegades i despres fes un dmesg. Mira si a les ultimes linies hi apareix alguna cosa que hi diu setkeycode bla bla.

Un altra cosa que pots fer es obrir el programa acpi_listen i pitjar-lo, a veure si t'el reconeix.


salut

Diegstroyer
March 30th, 2009, 03:26 PM
No està activat de forma predeterminada? Has provat prémer Fn+"el botó que dius"?

Aquesta opció funciona igual (l'ubuntu ho configura) que si utilitzessis Windows.

Salutacions

jinglada
March 30th, 2009, 10:53 PM
No està activat de forma predeterminada? Has provat prémer Fn+"el botó que dius"?
Aquesta opció funciona igual (l'ubuntu ho configura) que si utilitzessis Windows.

El touchpad està activat de forma predeterminada i el botó serveix per a desactivar-lo amb la finalitat d'evitar els moviments del cursor no desitjats que es puguin produir a l'hora d'utilitzar el teclat. Es tracta de l'opció més útil en el cas de que es tingui connectat un ratolí a l'ordinador. El botó s'encén quan el touchpad està bloquejat.
En Windows s'activa i es desactiva simplement prement el botó. En Ubuntu el botó no funciona i no s'encén al prémer-lo, ni amb Fn ni sense. He optat per la opció de desactivar els clics del touchpad a les preferències del ratolí:
http://ubuntuforums.org/picture.php?albumid=1000&pictureid=3592



Et dic el mateix que a l'altre fil, la solucio comença de manera igual:

Prement el botó vàries vegades i fent un dmesg no apareix cap vegada la paraula setkeycode en les 446 línies mostrades pel Terminal.

En canvi l'acpi_listen dóna el següent:

joan@joan-laptop:~$ acpi_listen
hotkey ATKD 0000006b 00000011
hotkey ATKD 0000006b 00000012
hotkey ATKD 0000006b 00000013

Salut i gràcies a tots dos.

Razlo
May 2nd, 2010, 12:13 PM
ostres, jo tinc el mateix problema! No es pot associar el botó a l'opció "Habilita el ratolí tàctil" que surt a la captura?

jinglada
May 2nd, 2010, 01:15 PM
ostres, jo tinc el mateix problema! No es pot associar el botó a l'opció "Habilita el ratolí tàctil" que surt a la captura?
Al cap de més d'un any, i havent migrat a l'Ubuntu 9.10 Karmic Koala, seguix tot igual pel que fa al botó, però a les preferències del ratolí hi ha variacions.
http://ubuntuforums.org/picture.php?albumid=1000&pictureid=6040

Razlo
May 2nd, 2010, 08:11 PM
Doncs amb el lucid lynx les opcions són exactament les mateixes. El que preguntava, per això, és si no es podria programar botó físic del portàtil per (des)habilitar el tàctil.

Crec que em crearé un llançador a la barra que ho faci a través d'un script, però sempre és més còmode si ja tens el botó a la carcassa...

pelai21
May 2nd, 2010, 08:52 PM
Jo tinc el mateix problema que vosaltres. I és molt molest, perquè el meu touchpad és molt sensible. El botó està permanentment encès i encara que el lucid inclou la pestanya de ratolí tàctil, no em fa cap efecte. També he provat algunes aplicacions que corren per internet, sense resultats. Pel que sembla hi ha moltes persones amb el mateix problema. Vaig trobar una solució que, teòricament, havia de funcionar:

http://ubuntuforums.org/showpost.php?p=8590673&postcount=9 (http://ubuntuforums.org/showpost.php?p=8590673&postcount=9)

però a mi no m'ha servit. Si trobeu una solució, feu-ho saber.

Razlo
May 2nd, 2010, 09:17 PM
'Device Enabled' equival a 121
$ID s'ha de canviar pel nom del touchpad

xinput set-int-prop $ID 121 8 0 #disables touchpad
xinput set-int-prop $ID 121 8 1 #enables touchpad

Per saber la id del tàctil:

~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Logitech USB Receiver id=9 [slave pointer (2)]
⎜ ↳ Logitech USB Receiver id=10 [slave pointer (2)]
⎜ ↳ HID 0a5c:4503 id=12 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=15 [slave pointer (2)]
⎜ ↳ Macintosh mouse button emulation id=16 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Sleep Button id=8 [slave keyboard (3)]
↳ HID 0a5c:4502 id=11 [slave keyboard (3)]
↳ Video WebCam id=13 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=14 [slave keyboard (3)]

Hauria de sortir algo així. Si no has canviat 'ImPS/2 Generic Wheel Mouse', que és el que surt al teu link, canvia-ho pel nom o per la id, més fàcil. Potser funciona :)

pelai21
May 2nd, 2010, 09:39 PM
Razlo, demà ho provaré a veure què passa. No hi entenc massa, però em sembla que pot funcionar. De moment he trobat una solució provisional. He eliminat el paquet xserver-xorg-input-synaptics i em funciona molt millor. Ara el touchpad em funciona com un mouse normal i corrent, però almenys no em balla de forma descontrolada i puc utilitzar sense problemes un processador de textos.