View Full Version : [ubuntu] 8.10 install in virtualbox, no internet connection

March 29th, 2009, 01:02 AM
I've just installed 8ubuntu 8.10 in a virtualbox vm. I don't seem to have an internet connection so far. That last ubuntu I installed was 7.04 and I think it may have been enabled by default? Or am I remembering wrong. In any case, how do I get an internet connection going?

Just checked the 8.10 docs and they state that a wired network connection should just work.

March 29th, 2009, 01:13 AM
In the docs at


I've pinged ubuntu.com with no success but did find the worked. So it's a dsn issue.

But then the page ends with "If the address is found then try the next stage." What next stage?:lolflag:

March 29th, 2009, 01:20 AM
have you already let virtualbox use the network connection that is your internet? that might solve it.

March 29th, 2009, 01:31 AM
thanks for the reply. it's my first virtualbox vm, so i'm not sure what you mean? I've used vmware before. anyways, can you tell me how/where to try that? it sounds like a likely candidate for a fix.

March 29th, 2009, 04:51 PM
Well, today it just works. It was a dns issue but for some reason after having the host off for 8 hours, thing came out right. Can anyone tell me what might have been the cause? I'd rebooted the guest os after each mod I made (like static ip).

April 2nd, 2009, 02:49 AM
Argh. Today for some reason my internet connectivity has vanished again.

I uninstalled all nvidia drivers on the system because I have also been stuck at 800x600 from day one. I don't know if this might have triggered the network issue.

Anyways, today the network config dialog is very strange. I'm on a wired network. The entry is called Auto eth0. It never worked with dynamically assigned IP via dhcp (which my router should have handled) but did prev work with a static IP. Today it was set back to automatic (DHCP). I use the IPv4 tab. I've reset it many times to day and it does not stick to the static IP. In fact most of the time after I set the gateway, the gateway value is reset to After I reboot the entire thing has reverted to automatic ip and still fails. I've tried a couple of static ip addresses.

I've had more difficulties with this release of unbuntu so far than any other, out of the gate.

Slim Odds
April 2nd, 2009, 03:09 AM
I've had more difficulties with this release of unbuntu so far than any other, out of the gate.

Are you using NAT or host interface?

You're probably having problems because you don't understand how VirtualBox works.

If you're using NAT, then the DHCP server is provided by VirtualBox and not your router. Also for NAT (from the VirtualBox docs):

6.4.3 NAT limitations
There are four limitations of NAT mode which users should be aware of:
ICMP protocol limitations: Some frequently used network debugging tools (e.g.
ping or tracerouting) rely on the ICMP protocol for sending/receiving messages.
While ICMP support has been improved with VirtualBox 2.1 (ping should now
work), some other tools may not work reliably.

April 2nd, 2009, 03:16 AM
OK, you probably hit the nail on the head there...I'll check that out. Thanks...yes NAT.

But anyways, if the virutalbox is acting as a dhcp server, and the default setting of the ubuntu network listing is automatic, why isn't it working?

April 2nd, 2009, 06:22 PM
Setting the virtualbox vb to use host interface seems to have helped. Thank you.