PDA

View Full Version : [ubuntu] DVD's no longer play........again



Fenris_rising
March 26th, 2009, 12:30 AM
Hi all

I am having a slight problem with watching DVD's. Now I have had them working before having been via the guides dealing with medibuntu, W32codecs etc etc etc. This morning I tried a genuine DVD movie disk and I got the error in Totem movie player;


Failed to connect to stream:invalid argument

So I tried Mplayer just in case but I got this;


Error opening/initializing the selected_out(-vo) device

Followed by (having clicked OK) I get


AO:[pulse]Failed to connect to server:Invalid argument

Except Mplayer plays the audio track only. Now After this morning I simply had a go, no luck, reinstalled the OS medibuntu etc etc etc all fixed :)

But it's all fallen over again. Other than the 350 odd updates after the install the only DVD/CD related program I have added to the list of;

Amarok, Audio CD extractor, Brasero burning disk, Movie player and Mplayer is DeVeDe. Can anyone else give me a clue as to what is going on?
Is there a fault in the updates currently? Or am I unlucky :( BTW I have Ubuntu 8.04


Further to this I have downloaded smplayer. Within this program I was presented with a set up page. Initially it wouldn't play anything as the others had failed to. Now At a wild prod and guess I changed the video option to x11 and the audio to Alsa........smplayer now works like a charm. So what does this indicate of the settings elsewhere that may be the problem and what changed them? I would like to get the other progs back up to snuff please.

Interestingly, yet again, I tried amarok and that was stuffed as well. I changed the 'autodetect' in 'engine' from auto detect to Alsa to get sound output. This is the first time in 10 months of ubuntu use where I have had such a failure. whether it's me or 'it' remains to be seen.

regards

Fenris

Fenris_rising
March 26th, 2009, 04:24 PM
Bump :)

Fenris_rising
March 27th, 2009, 02:40 PM
Noticed that some updates today were for regressing xine files. Is this because the problems were caused by broken files? smplayer is still the only functioning video player as yet though.

Does anyone know what is occurring?

regards

Fenris

Fenris_rising
March 27th, 2009, 03:12 PM
DBL post

Fenris

Fenris_rising
March 28th, 2009, 11:49 AM
Hi there

Only me! I have just installed, at my step daughters behest, Ubuntu 8.04 on her PC. Yesterday amarok worked and so did Totem. After updating today Amarok required me to go into the engine tab and set it to Alsa for it to work and Totem also refuses to play so smplayer is being Dl'd and installed as I know this works.

This is inline with what happened on my PC with a fresh install and on my EEEPC.....I am 100% sure it's not me sooooo-

Just one question........ what is going on, somebody just tell me PLEASE!

regards

Fenris