View Full Version : [ubuntu] newbie needs boost 1.33.1 on Hardy

March 23rd, 2009, 11:07 PM
at least I think I do ???

I have been trying to install a package that has a dependency on libboost-xxx1.33.x, and I get the error

Depends: libboost-regex1.33.1 (>= 1.33.1-10) but it is not installable
E: Broken packages

Firstly, I don't really know what this means - any help appreciated

In Synaptic Package Manager, one of the packages I can select is libboost-xxxx1.34.xx, but this doesn't help ie I get the same error.

Does this mean I need to install v1.33 specifically?

Do I need to add a new source to sources.list for v1.33?

If so, how do I find out about sources?

So far I have tried other suggestions:

sudo apt-get -f install
sudo apt-get update
sudo apt-get dist-upgrade

I am now trying another suggestion which was to build the boost libraries v1.33 from source

all help appreciated