View Full Version : [ubuntu] No hard drive found during install

March 20th, 2009, 02:45 PM
I have a brand new computer with a 640GB WD Green HD. P6T Motherboard, i7 920 CPU.

During the install, no hard drives show up in the list at the partionner step. I have googled for solutions and found no answer that fixed it. What I've tried:

fdisk -l returns nothing when running under live session
Unplugged every non essential peripheral hardware (printer, external HD, etc).
Tried Enhanced and Compatible mode for my SATA options in the BIOS

March 20th, 2009, 07:19 PM
This might be due to the Linux kernel modules on the live CD being incompatible with your hardware, in particular the disk interface. Here is a thread (http://ubuntuforums.org/showthread.php?t=995231) that talks about some of the problems people have seen with this type of motherboard.

It is possible that the kernel on the Live CD won't see your drive, but the kernel on the Alternate Install CD might. I would recommend trying that first.

March 22nd, 2009, 05:51 PM
It was my bad, I was using my old 8.04 CD instead of my new 8.10 one. The 8.10 detected the HD with no problem. Thanks for the tip!