View Full Version : [ubuntu] 8.10 won't boot after successful installation on Pavilion 700

March 19th, 2009, 05:04 AM
Hey, first time posting after tons of lurking (and getting tons of help over the last year).

I installed Ubuntu 8.10 on my in-law's HP Pavilion 700 seemingly successfully. This was the graphical installation and it made it all the way through, ejected the disc, and rebooted. On reboot, the loading screen appears, does its thing, and then a black screen appears. No cursor, login screen, nothing.

I also tried my Xubuntu 8.10 text only installation and had similar results. No cursor, login, etc. Both installations seemed successful.

I then tried Ubuntu live CD without much more luck, though this time the cursor DID appear.

There's very little on the these forums relating to the Pavilion 700... so this might be new ground. I'm assuming it's something relating to the video driver, and I'm using the onboard chip, though I'm not sure what chipset it is (general information on the tower is limited on HP's site).

Thanks in advance for the help!

March 19th, 2009, 11:19 AM
If you get the grub menu, and then the loading process gets no login screen and so forth, then I would agree that it is a video/graphic problem.

Is there a 'safe mode' option, and does that get anywhere?

What I'd be looking for is a way to get to 'single user' mode (rather old term for non-graphics level mode) where you can hand-configure the xserver. I don't, at the moment, know how to get to this mode with ubuntu 8.10.

There are utilities which can probe the hardware to decide the chipset and capabilities - the xserver config package has some, which might help. I'm still trying to find just what has been loaded as part of the 8.10 install, as there is some bits which don't seem now to be included automatically.

March 19th, 2009, 01:41 PM
Interesting, I'll definitely look into that. Though I have no special connection to 8.10, so if you know if an older version would be more compatible, let me know.

March 19th, 2009, 05:09 PM
This sounds like a similar problem I had, doesnt look like grub has been installed correctly during install.

Boot into rescue mode and reinstall grub on the correct partition.

March 19th, 2009, 07:38 PM
I haven't found a way to get 8.10 to boot single-user mode, yet, but following your query about earlier versions, some hardware is known to react better to 8.04.r2 - may be worth a try.

March 21st, 2009, 01:42 AM
In order to get a clearer picture of your setup, I suggest to boot from the Xubuntu LiveCD and download the Boot Info Script to your desktop:


Then open a terminal (Applications > Accessories > Terminal) and type:

sudo bash ~/Desktop/boot_info_script*.sh

That will create a "RESULTS.txt" file in the same directory from where the script is run, namely your desktop; please copy/paste the contents of the RESULTS.txt file to your next post, highlight the copied text, and click the pound/hash sign "#" graphic button in the Ubuntu forum message box so that the text will get "code" tags put around it. The results of that script will help clarify your setup and hopefully what the solution to your booting problem might be.

March 21st, 2009, 05:07 PM
Unfortunately I can't even boot from the 8.10 Live CD, I get a mouse cursor but that's it when I try that. Anything else I can try related to that? Otherwise I'm going to investigate the grub solution.

March 21st, 2009, 06:15 PM
After examining the script suggested, I cannot see it contributing anything useful, as it merely looks at hard disks, partitions, and boot possibilities.

We've already established that the installation gets to do the loading, having selected Ubuntu, so we should concentrate on the graphics problem, and how to solve it.

I've already suggested trying 8.04.r2, and would now further suggest trying DSL and Mint - both of which have been better at performing on tricky graphics hardware. If either of these can generate a clearly visible result from a live CD, then we can progress.

March 21st, 2009, 06:26 PM
After examining the script suggested, I cannot see it contributing anything useful,

I agree. I must have misread the orginal post. Sorry for the interruption.

March 21st, 2009, 07:58 PM
Thanks for the suggestions, I'll start downloading at least 8.04r2 now.

March 27th, 2009, 02:22 AM
Sorry, been really busy lately, just got around to the computer again.

8.04.2 worked great via Live CD, so I'm just going to try doing a full install now. I think the first thing I'll try is to update to 8.10, but if anyone wants to theorize on what is going on, I'm game.

UPDATE: I was able to install 8.04.2 without issues and the update to 8.10 went smoothly. Thanks for all the suggestions.

March 27th, 2009, 04:36 PM
Glad to hear that's fixed.

March 27th, 2009, 07:14 PM
FYI, I had a similar situation with a Compaq EVO 510. This is the solution I found on antother post here...

Might be the same black screen problem I've been getting with Intel graphics since Aug 13. Excerpting Developers comments from my Launchpad Bug #259385:

"== Desktop effects and Intel 830MG and 845G video cards ==

There is a bug in the intel video driver for the older intel 830 and 845 integrated video cards that are used on laptops like the IBM R30. Desktop effects with compiz will not work on those chips and freeze the system."

From what I've seen on the posts there are a LOT More chips that have symptoms like this.

My workaround is:
Boot in rescue mode
select root shell prompt
sudo apt-get remove compiz
sudo apt-get remove compiz-core

If that works you're O.K. except no special visual effects. If you want to try compiz again, install with Synaptic.