View Full Version : Steam games wont launch

March 15th, 2009, 08:14 PM
-I've recently installed Ubuntu 8.10 and all up the updates.
-I have Wine 1.1.17 installed, so everything is up to date.
-I can start up Steam successfully, chat with my friends, install games and everything just fine.
-But when I try to launch the games, it only goes as far as "Preparing to launch (insert game here)....."

I have no clue what could be wrong, ive tried -dxlevel 81 and 70, neither improved anything.

I'd really rather not have to reinstall windows, i'm so tired of it.

Thanks in advance,

March 15th, 2009, 09:22 PM
Does it just stop with "Preparing to launch" or is there some error box?

Also how long do you wait for the game to load is sometimes it can to a minute or two when launching a game.

And finally the -novid command is awesome, I have never got steam games to launch reliably in Windows or wine without -novid.

March 15th, 2009, 09:25 PM
No error box appears, just "preparing to launch"

March 15th, 2009, 09:27 PM
I could wait all day, it wont come up.

March 15th, 2009, 09:46 PM
We need to find out what the error is that is stopping the games from loading.

Please could you open a terminal window and run:

env WINEPREFIX="/home/YOURUSERNAME/.wine" wine "C:\Program Files\Steam\Steam.exe"

Obviously change the path highlighted in red. What does it say when you try to run a game (And what is the game)?

March 15th, 2009, 10:34 PM
Typed it in, nothing happened.
Like i said, it just says preparing to launch... I tried it on three games,
Preparing to launch: Counter-Strike: Source
Preparing to launch: Team Fortress 2
Preparing to launch: Left 4 Dead

March 15th, 2009, 10:54 PM
Even though steam will say the "Preparing to launch" the terminal window will give us the information we require to help you.

See attached example of me running:

env WINEPREFIX="/home/MYUSERNAME/.wine" wine "C:\Program Files\Steam\Steam.exe"

Make sure that steam is not already running when you run the command (We want the command to launch steam).

In the example I ran Half-life 2.

March 15th, 2009, 11:05 PM
Oh, I had to exit Steam and then run that command in the terminal.
heres the last few lines, wasnt sure how much you needed

March 15th, 2009, 11:09 PM
Thank you, Wine is stating that your graphic card drivers may not be installed correctly or at all.

What graphic card have you got?

March 15th, 2009, 11:12 PM
Nvidia GeForce 7900 GT

March 15th, 2009, 11:15 PM
On the top panel of your desktop click on:

System > Administration > Hardware Drivers

Then pick the "Recommended" driver and follow the on screen instructions, reboot your PC and then try running the game again.

March 15th, 2009, 11:52 PM
Okay, so I had the 96 drivers installed. I tried both the 177 and 173 and both started my computer into low graphics mode until i fixed it. So, there are no other drivers to try, I dont know what to do.

March 16th, 2009, 12:08 AM
I did, and thats when It boots into low graphics mode and forces me to change it

March 16th, 2009, 12:43 AM
Well, I hate to give up on Linux, especially after learning all the commands and getting used to it. But with the crappy drivers, I guess i'll be back to XP ._.

March 16th, 2009, 07:28 PM
As you wish, just post back here if you encounter this issue again.

However ;) you could run:

glxinfo | grep render

It should output something like:

direct rendering: Yes
OpenGL renderer string: GeForce 8800 GT/PCI/SSE2
GL_NV_depth_buffer_float, GL_NV_conditional_render, GL_NV_depth_clamp,
GL_NV_vertex_program3, GL_NVX_conditional_render, GL_SGIS_generate_mipmap,

This means that the graphics drivers should be installed and working.

March 19th, 2009, 11:20 PM
direct rendering: Yes
OpenGL renderer string: Software Rasterizer
thats all

March 20th, 2009, 12:10 AM
Welcome back. :)

Please could you post the contents of the 'xorg.conf' file located in '/etc/X11' folder.

Here is mine, I have an Nvidia 8800GT, since you have a 7900GT yours probably should be similar:

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24

Section "Module"
Load "glx"

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"

The two highlighted parts seem to be important to loading the drivers.

March 21st, 2009, 02:12 AM
After reinstalling XP twice, I decided it totally wasnt worth it, and I'd go back to Ubuntu and try another few things.
8.10 Intrepid Ibex still wasnt working with my GeForce 7900, so I upgraded to Jaunty Jackalope, installed the recommended (180?) drivers, and now everything launches.
One thing I cant quite figure out though, if you could help me.
I launch the games, of which are full screen, and when I do, the Taskbars/Panels are still showing, so i cant move my mouse and click on buttons correctly in-game. Any way to make the Taskbars/Panels disappear when I launch something fullscreen?

March 21st, 2009, 01:18 PM
Nice, You could try right clicking on the panels, selecting properties and then picking 'Autohide '.

March 21st, 2009, 01:23 PM
I found that steam wouldn't even connect with the latest wine build due to some odd regressions, so I installed the one from the official ubuntu repo (1.0.1) and that fixed the problem.

March 21st, 2009, 05:46 PM
Oh, I got Crossover Pro.

I tried autohide, but I want the panels there, just not when i launch something fullscreen, autohide makes them disappear whenever im not clicking them.

March 21st, 2009, 10:40 PM
Right-click the taskbar. Choose Properties. Enable "Show hide buttons" (and "Arrows on hide buttons" if you'd like).

Now if the bars get in the way of a game, you can slide them out of the way using the hide buttons.