View Full Version : [ubuntu] Cannot activate screensaver

March 14th, 2009, 03:38 PM
Thought I'd see if anyone has suggestions on how to fix this. My screensaver won't activate, I see the screen start to darken but as soon as it goes to load, it pushes back to the desktop. I have swapped between a few different screensavers to see if it was that but it's the same result every time. I don't remember doing any major changes however I also haven't used the screensaver since before I installed nVidia 180 gfx drivers (there has been numerous updates to the laptop since then).

I have the Pangolin Performance (purchased this last January).

I'm going to try backdating my drivers and see if that solves the problem.

March 14th, 2009, 04:19 PM
FYI, that had no effect...

I managed to get a work around going by having it lock the computer when it activates the screensaver.

March 14th, 2009, 05:50 PM
Have you tried xscreensaver (http://en.wikipedia.org/wiki/Xscreensaver)?

March 14th, 2009, 09:07 PM
Nope, just wanted to get the ones that came installed with Ubuntu to work. They used to. Just stopped working for some reason. I also had to disable the screen turn off functionality because the screen wouldn't come back on :)

March 16th, 2009, 03:37 PM
I managed to get a work around going by having it lock the computer when it activates the screensaver.

That sounds like it could be an xserver or an nVidia bug. I'll run some tests on it and see if I get the same problem.

March 18th, 2009, 04:39 AM
I thought it was an nVidia bug but I still had it when I back dated to 177 for driver. It's not a huge issue since screensavers are pointless these days without the account lock. The screen shut off is more of an annoyance to me now simply because it's a power saving feature that isn't available (granted, I'll probably suspend the comp when not doing things).

March 25th, 2009, 03:48 AM
thomas: how did your tests go?

March 25th, 2009, 05:10 PM
Sorry, I forgot to post back.

I'm getting the same thing, with or without compiz enabled.

I think it is this bug...


We're smack in the middle of Jaunty testing now. I'll report back on whether or not it is fixed there.

March 27th, 2009, 03:47 AM
Fantastic, that is exactly the bug. If it's fixed in Jaunty, yay, otherwise, oh well.