PDA

View Full Version : [ubuntu] modprobe : FATAL: Could not load /lib/modules/2.6.27-11-generic/modules.dep



BiynaYahu
March 13th, 2009, 04:03 AM
modprobe : FATAL: Could not load /lib/modules/2.6.27-11-generic/modules.dep

socket: Address family not supported by protocol - make sure CONFIG_PACKET (Packet socket) and CONFIG_FILTER (Socket Filtering) are enabled in your kernel configuration!

when I perform the command dhclient eth0 I receive this error.

P.S. Sorry, in my haste I forgot some of the error.

BiynaYahu
March 16th, 2009, 03:37 AM
*bump*

BiynaYahu
March 16th, 2009, 05:52 PM
*bump*

APNelson.L
March 16th, 2009, 06:57 PM
Is this causing you to have internet connectivity problems? I get a similar error but I can connect fine.

You may want to try modinfo dhclient and post back the results. My computer does not even see dhclient as a module though.

cariboo
March 16th, 2009, 07:06 PM
Is there a modules.dep file located in the path indicated by the error message?

Jim

BiynaYahu
March 20th, 2009, 01:20 AM
When I use: modinfo dhclient . I get: modinfo: could not open /lib/modules/2.6.27-11-generic/modules.dep

No, there is no file at that location in fact the only folder contained within '/lib/modules' is '2.6.27-7-generic/'

BiynaYahu
March 23rd, 2009, 07:17 PM
*bump*

Bachstelze
March 23rd, 2009, 07:19 PM
Do this:


sudo depmod -a

Then try again.

BiynaYahu
March 24th, 2009, 12:01 AM
Do this:


sudo depmod -a

Then try again.

When I did the command you posted I received this error:

WARNING: couldn't open /lib/modules/2.6.27-11-generic: No such file or directory
FATAL: could not open /lib/modules/2.6.27-11-generic/modules.dep.temp for writing: No such file or directory

Bachstelze
March 24th, 2009, 12:03 AM
Your system is severely messed up, the. Best think to do is to try reinstalling your kernel (and pray):


sudo apt-get install --reinstall linux-generic

BiynaYahu
March 24th, 2009, 12:22 AM
Your system is severely messed up

Yeah, I'm good at that.

BiynaYahu
March 24th, 2009, 01:25 AM
So, I gave up and formatted my root directory (it's on it's own partition). So, I suppose this thread is solved for all intensive purposes, but since it was such a crappy solution I'm going to refrain from setting this thread to solved.

tusseyd
October 12th, 2010, 01:53 AM
I tried the "sudo depmod -a" that Ken Thompson recommended, and that seemed to have fixed the problem. Thank you.