PDA

View Full Version : [xubuntu] no DNS from USB stick



pdc124
March 12th, 2009, 08:22 PM
ive installed xubuntu 8.1 on a compaq evo N410c and theperformance is good enough.

Ive added a wireless USB stick

root@ros-laptop:~# lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@ros-laptop:~#


it gets an IP address but i have no DNS


t@ros-laptop:~# ping www.google.com

ping: unknown host www.google.com

root@ros-laptop:~# ping -c4 192.168.0.254

PING 192.168.0.254 (192.168.0.254) 56(84) bytes of data.

From 192.168.0.245 icmp_seq=1 Destination Host Unreachable

From 192.168.0.245 icmp_seq=2 Destination Host Unreachable

From 192.168.0.245 icmp_seq=3 Destination Host Unreachable

From 192.168.0.245 icmp_seq=4 Destination Host Unreachable



--- 192.168.0.254 ping statistics ---

4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3018ms

, pipe 3

root@ros-laptop:~# ifconfig

eth0 Link encap:Ethernet HWaddr 00:d0:59:c6:fb:c8

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



eth1 Link encap:Ethernet HWaddr 00:50:04:cc:6a:62

inet6 addr: fe80::250:4ff:fecc:6a62/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:11 errors:0 dropped:0 overruns:0 carrier:11

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:2178 (2.1 KB)

Interrupt:3 Base address:0x300



lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:62 errors:0 dropped:0 overruns:0 frame:0

TX packets:62 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:5176 (5.1 KB) TX bytes:5176 (5.1 KB)



wlan2 Link encap:Ethernet HWaddr 00:11:3b:13:d0:34

inet addr:192.168.0.245 Bcast:192.168.0.255 Mask:255.255.255.0

inet6 addr: fe80::211:3bff:fe13:d034/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:130 errors:0 dropped:0 overruns:0 frame:0

TX packets:136 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:9244 (9.2 KB) TX bytes:11650 (11.6 KB)



wmaster0 Link encap:UNSPEC HWaddr 00-11-3B-13-D0-34-30-33-00-00-00-00-00-00-00-00

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



root@ros-laptop:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

192.168.0.0 * 255.255.255.0 U 2 0 0 wlan2

link-local * 255.255.0.0 U 1000 0 0 wlan2

default 192.168.0.254 0.0.0.0 UG 0 0 0 wlan2

root@ros-laptop:~#


root@ros-laptop:~# cat /etc/resolv.conf
# Generated by NetworkManager
domain home.nw
search home.nw
nameserver 192.168.0.254

if I plug a cable in a get a connection ( same NW - ive got a wireless access point)
after plugging the cable in reolv.conf is this
root@ros-laptop:~# cat /etc/resolv.conf
# Generated by NetworkManager
domain home.nw
search home.nw home.nw
nameserver 192.168.0.254
nameserver 192.168.0.254
root@ros-laptop:~#

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 1 0 0 eth0
192.168.0.0 * 255.255.255.0 U 2 0 0 wlan2
link-local * 255.255.0.0 U 1000 0 0 wlan2
default 192.168.0.254 0.0.0.0 UG 0 0 0 eth0
root@ros-laptop:~#

so why havent I got DNS from the wireless stick ?

jdelasalas
March 12th, 2009, 10:51 PM
If you have wireless on your laptop and usb dongle. This may work for you, I had to disable the wireless on my laptop for the dongle to actually work. When both the laptop's wireless and the dongle's wireless was running neither would connect to the network.

That may have just been for me.

pdc124
March 12th, 2009, 11:21 PM
no native wireless