View Full Version : How do I deal with a "fixme" when trying to run a windows exe?

March 8th, 2009, 05:57 PM
What is the approach to 'fixing' this kind of thing?

fixme:ole:OLEPictureImpl_SaveAsFile (0x12f1a0)->(0x131f50, 0, (nil)), hacked stub.

This was attempting to run an exe (compiled VB5 code) under wine. It is the first time I have tried to run this particular one, which uses an Access Database, although it cannot have got as far as trying to do that yet. The superficial error (reported by a Windows-style error box) was "Error 11 - division by zero"

March 8th, 2009, 08:45 PM
Wine really can't run all windows programs, most of them are malfunctioning or don't work at all.

Or maybe it's a bug in the program you are trying to run? "Division by zero" sounds one to me.

Whenever I run any programs under wine, I get lots of fixmes, even if the program is working correctly.

March 9th, 2009, 11:24 PM
I don't think it is likely to be a bug. It is a prog I have been running for a long time on my W95 machine. The first thing it does is ask the user which input file to use, but under wine it doesn't even get that far.

But my point is.... supposing the 'fixme' is fixable, how do I find out how?

March 10th, 2009, 12:36 AM
It means an API call that the program is using has not been reimplemented in Wine.

You can check the Wine App database (http://appdb.winehq.org/) to see if they have a workaround. But aside from that, I don't think there's anything you can do about it until it gets written, unless you want to go write it yourself...