View Full Version : [ubuntu] Intrepid 8.10 Printer problems

March 7th, 2009, 08:49 PM
Further to my request for help in getting my printer working ( see below ) I have gone back over recent threads and found this is not an isolated problem , in fact there are several related requests for help .
Is this since a recent update ? If so should I report it ?

March 8th, 2009, 03:37 AM
there is nothing hear which states what printer you are using

March 8th, 2009, 04:33 AM
What printer are you trying to install?

March 8th, 2009, 10:25 AM
Before the recent update I already had my HP deskjet 3822 running perfectly , with the small picture of a printer in the top right hand corner , but now I can't get the cups scheduler to run and it's missing from admin services and when I try to connect to local host , I get connect encrypt failed .

March 8th, 2009, 03:23 PM
Did you look at:


March 8th, 2009, 03:24 PM
Did you look at:


I know for sure that HP DeskJet 3822 is supported by HPLIP => 0.9.5

March 8th, 2009, 03:54 PM
I have just transferred to another computer which also has Intrepid 8.10 and my printer works fine on that , but it hasn't been updated . I feel sure it's something to do with a conflict between cups and cupsys since I updated .

March 8th, 2009, 04:07 PM
Is your printer shown in System/Administration/Printing?

March 8th, 2009, 04:24 PM
No it isn't , this is the problem , since I updated there no is connection with the printer , though it is still shown in the /etc/cups folder . I have tried everything I can think of to get cups scheduler to restart but nothing doing . Fortunately as I say I have a spare computer which I can use if I need to print anything , its just that that one is a lot older and slower.

March 8th, 2009, 04:27 PM
let's see if CUPS is there

sudo apt-get install cupsys gnome-cups-manager

March 8th, 2009, 04:27 PM
What is the output of

dpkg --get-selections | grep cups
This should list all the cups related packages you have installed.
I'm thinking that maybe if we can figure out the right package to remove and then reinstall, the problem might be fixed.

March 8th, 2009, 04:32 PM
Have tried that and also reinstall from package manager, cups is there alright I can see it in my file system folder , it just refuses to configure . By the way forgot to say " thank you " for all the time you are spending with me on this .

March 8th, 2009, 04:35 PM
Don't mention it. That is what this forum is all about. Do as ubuntbu said and run dpkg --get-selections | grep cups. Obviously, he's more experienced with this, so, best of luck!

March 8th, 2009, 04:42 PM
Please excuse me for a minute , as I say I have moved over to my spare old computer so I can print out any replies , will have to switch back to the other which I am having problems with so I can post the output .

March 8th, 2009, 04:49 PM
I too had an issue where it didn't want to Print for me and instead froze indefinitely.
I just created a New Printer and deleted the old one.

Works now

March 8th, 2009, 04:54 PM
Back now on the newer computer with the problem since updating cups . The message I get from grep is " cups purge " As I read in another thread someone suggested there is a change between cups and cupsys which may be the problem .

March 8th, 2009, 05:06 PM
Have just done a comparison between my two computers and the one that prints says in the print server box " /var/run/cups.sock ", but in the one that doesn't work it says " local host " and thats the one it wont connect to . Any help ?

March 8th, 2009, 05:14 PM
Well, it looks like that is supported:


Read my post #3 here:


March 8th, 2009, 05:26 PM
Well I think we have spent enough time on this so I will thank everyone that has made suggestions and just assume the update I did was a bad move and not automaticaly do updates when they pop up .

March 9th, 2009, 02:00 PM
That is how completely I lost sound once :-)