View Full Version : [kubuntu] Unable to open Adept Manager / Sudo errors

Red Rhino
March 5th, 2009, 09:26 PM
I recently installed Kubuntu 8.04, within the past week, and have just now starting having a problem with opening the Adept Manager or using Sudo. Both of these programs were working fine yesterday. When I try to open Adept Manager, the program attempts to start then closes. When I try to issue a sudo command line, I get the following error:

>>>sudoers file: syntax error, line1 <<<
sudo: parse error in /etc/sudoers near line 1

It does not matter what command I use with sudo it returns the same error. The last thing I setup on my machine was Smb4k, this probably has something to do with it, but not sure what. The Smb4k is working fine so I hope I don't have to uninstall this to get sudo working as I do need to access Samba shares.

As someone that is still new to Linux, any help would be appreciated.

March 5th, 2009, 10:31 PM

Red Rhino
March 5th, 2009, 11:48 PM
I tried your suggestion and here is what happened:

Case #1 - adduser says that I am already a member of admin
Case #2 - unable to run sudo commands due to problem stated above
Case #3 - returned no errors, but problem still exists.


March 5th, 2009, 11:58 PM
According to your error message from your OP, there is something wrong with /etc/sudoers, near the top. Did you check your /etc/sudoers while you were in the recovery mode?

Otherwise, post it here.

Red Rhino
March 5th, 2009, 11:59 PM
I was eventually able to get into the /etc/sudoers file and found that on the first line was the word PASSPROMPT

I do not know what this command or word represents, but when I removed it and saved the file the sudo command began to work again, including Adept Manager.

Thanks for the help!