PDA

View Full Version : [xubuntu] ndiswrapper stops



aaronhahn777
March 4th, 2009, 07:10 AM
I've only been using ubuntu since christmas and I am having some difficulties with "sudo modprobe ndiswrapper"

I installed a d-link usb wireless device (took me forever), but now I find that the wireless often cuts out after using it for some time.

I've been reading other similar posts ( http://ubuntuforums.org/showthread.php?p=1809544#post1809544 ), but I cannot solve this one on my own. I don't want to do a fresh install and I had a feeling the following file contents might help.

Any tips would help. Thanks in advance.

Here is my /etc/network/interfaces:
# The loopback network interface
auto lo
iface lo inet loopback

Modules file:
# modules loading at boot
loop
lp
fuse
ndiswrapper

My blacklist file:
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m)
blacklist snd_aw
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp

kevdog
March 4th, 2009, 07:31 AM
Can you be more specific on what problems you are having with sudo modprobe ndiswrapper?

Thanks.

aaronhahn777
March 4th, 2009, 06:02 PM
My network manager will disconnect me from wireless after a few minutes of browsing. Sometimes I have 15 minutes, other times I only have a few seconds. After this, I am unable to start up the wireless again.

It's rather intermittent... sometimes the wireless works when I reboot., other times it doesn't. I tried removing "ndiswrapper" from "modules list" and manually running it from the terminal when I need it. But still, I run the command "sudo modprobe ndiswrapper" and it might or might not work. Furthermore, it will quit working after a few minutes.

I've read several posts and I think it has something to do with ndiswrapper. Should I use a different version? Perhaps something in my blacklist is causing another module to run (or not in my blacklist)?

Any help? (i'm a beginner in linux)

aaronhahn777
March 19th, 2009, 01:00 AM
just bought a "retail plus+ IEE 802.11B/G V1.0" and it worked flawlessly out of the box...

after wasting 40 hours with d-link and ndiswrapper... and almost going back to xp... dang that's nice (also cheapest one in the store... $24)


Simply:
>installed 8.10
>inserted usb stick
>enjoyed surfing

aaronhahn777
March 19th, 2009, 01:37 AM
second thought... sometimes it disconnects after surfing for some time.