View Full Version : [ubuntu] kernel upgrade emergency!

March 2nd, 2009, 10:01 PM
Hey all! I have a slight emergency. I just upgraded the kernel via the update manager and on reboot i get a blank screen after the usplash. I've left it for about 2 hours and still nothing...

What could it be?

March 2nd, 2009, 10:11 PM
Can you still boot with the old kernel from GRUB menu? If you don't see the menu when you turn on your machine, press Esc key to bring it up.

March 2nd, 2009, 10:27 PM
Its not listed. I used the start up manager to take out hte other entries! *won't* be doing that again haha.

March 2nd, 2009, 10:30 PM
Boot into recovery mode and pick the xfix. See if that fixes your X server.

March 2nd, 2009, 10:47 PM
Yh this allowed me to login but when i try and use the nvidia drivers, i get the same problem...

March 3rd, 2009, 12:06 AM
Which nvidia card do you have and which driver did you install?

lspci | grep VGA

March 3rd, 2009, 12:08 AM
I have this: -

01:00.0 VGA compatible controller: nVidia Corporation GeForce 9200M GS (rev a1)

I tried to install the nvidia 177 driver. The one that says (recommended) on it.

March 3rd, 2009, 02:23 AM
I'm currently using kernel .27-12 it seems to be working ok, so I'll carry on for the mean time.

March 3rd, 2009, 02:39 PM
Same problem here. My VGA is:
VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)

March 3rd, 2009, 02:43 PM
same problem here.
I can still boot with old kernel...;)

my nVidia card is
lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)

Hope this helps someone fix the problem.

March 3rd, 2009, 02:53 PM
Worked for me with the 180 drivers. I booted using the old kernel and installed the nvidia-glx-180 package. Hope this helps you folks too.


March 3rd, 2009, 03:37 PM
nvidia-glx-180 also need this package:nvidia-180-kernel-source
go here to download!

March 3rd, 2009, 11:26 PM
Ok. oroblem solved. now running latest kernel and nvidia 180.
Thanks guys!

Long live to Ubuntu and community!

March 4th, 2009, 01:32 AM
same problem here...blank screen with flickering horizontal stripes...i am back to older kernel now... :confused:

March 4th, 2009, 01:38 AM
Just finished doing the kernel upgrade on my lappy and ended up with the same problem as you all.

I'll ask for some help here at home to try and get my lappy back in working order with the new drivers, etc.

March 4th, 2009, 02:17 AM
I'm also having that problem; I just posted this :


How to install and activate this driver (180 ?)

I installed it but I don't see it under Hardware Drivers...

Edit: Ok, It activated while rebooting...

Did anyone reported the bug ?

March 4th, 2009, 04:23 AM
+1 on my laptop as well. Nothing in system logs to indicate any failures. Rebooting with .12 kernel works fine.

GPU: nVidia 8600M-GS

Question: Will updating to the 180 driver mess up my ability to boot into older (pre- .13) kernels?

I'm not going to mess with it right now. I need some time to get my heartbeat back down to normal. :eek:

March 4th, 2009, 06:26 AM
ok, after installing/uninstalling 180.11[intrepid] and 180.35[for jaunty?], compiz-check (http://forum.compiz-fusion.org/showthread.php?t=8383) opened up the "Hardware Drivers" app for me and... 180 is now there[and "recommended", whereas 177 was recommened before].

i think i had 180.35 installed[for the second time] while i did the compiz-check. i'll be back if anything else needs to be mentioned...

March 4th, 2009, 07:38 AM
I have the same problem after upgrading my ubuntu-8.10 from 2.6.27-12 to 2.6.27-13. I can see small differences in /var/log/messages. For example, both kernels have these lines:

input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:01/
ACPI: Video Device [NVID] (multi-head: yes rom: no post: no)

But only older kernel has the following lines after lines above:

input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:07/input/input11
ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)

I have not updated NVidia driver yet.

March 4th, 2009, 10:37 AM

March 4th, 2009, 11:53 AM
Installing 180.11 from Synaptic worked for me.
Installed the following:
nvidia-settings (think this was already installed).

Booting with.13 kernel a treat.

Edit: This was after xfix from recovery mode.

March 4th, 2009, 12:05 PM
same problem ++

March 4th, 2009, 07:00 PM
Same problem here

March 4th, 2009, 08:02 PM
Same issue with a Dell D820. Completely black screen.

March 4th, 2009, 08:04 PM
can confirm this problem, but it's fixed with the 180 driver..

thx for the hint!

Carlos Sevcik
March 4th, 2009, 10:03 PM
I posted this earlier this morning, its an update glich. Hopefully it wil be solved soon, but in while its solved, just boot your old kernel. You can set this as default by editing as root /boot/grub/menu.lst and modify:

# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default 0


# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default 2

You may do this using

sudo gedit /boot/grub/menu.lst

This will make the kernel installed before the last version to be your boot default kernel. Remember to change default back to 0 when they fix the bug to make the newest kernel your default.

March 6th, 2009, 02:08 PM
Thanks, I installed nvidia 180 and I got into kernel -13.

However, I went to System -> Preferrences -> Appearence -> Visual Effects -> Normal

and it tells me "nvidia 173 is required."

If I install this, will it create problems? What about the newly installed 180 ?

Thanks, Dinshaw

Ubuntu 8.10 on Dell Inspiron 6400 Laptop.

March 8th, 2009, 10:30 PM
I broke xserver and it won't come back :( I tried to install the latest driver for nvidia and it broke the graphics. I don't know what to do. I tried uninstalling and reinstalling but it doesn't work, it tells me to reconfigure each time...

March 9th, 2009, 11:30 AM
Just tried the two options suggested.

Upgrading the nvidia drivers to 180 meant I could boot 27-13, but I get a big 'beta' sign on the nvidia bootup screen, and indeed there were a few wierd things in gnome with this driver.

So for me booting tot he older kernel is the peferred option for now