PDA

View Full Version : [gnome] Visual Effects settings not saving.



theonemule
February 27th, 2009, 04:13 AM
Okay...in the Appearance settings, I set my Visual Effects to 'Extra', and the settings work fine.

Every time I restart my computer, the settings are back to 'None' and I have to manually reset Visual Effects back to 'Extra'

Any reason why this happens?

Thanks

snman3131
March 11th, 2009, 01:13 AM
I'm having the same problem, any luck?

Committed
March 11th, 2009, 02:04 AM
Have you installed compiz? Once I installed it and started using compiz settings manager the appearance/visual effects meant nothing and would not stay as selected. If your compiz effects are working, I wouldn't worry about it.

oneafrikan
May 20th, 2009, 07:33 PM
Nope, same for me with both compiz settings managers installed...
although the simple settings manager seems to crash after starting up...

any ideas?

_0R10N
May 1st, 2010, 02:10 AM
Same problem here!! I'm also having this problem with Cairo Dock. If I add a launcher, when I reboot it's not there...:confused:

CaptainPasty
May 1st, 2010, 04:51 PM
Same problem. Every time I log in I need to change the settings again.

_0R10N
May 1st, 2010, 05:02 PM
Same problem. Every time I log in I need to change the settings again.

I found this workaround in other thread here, add
/usr/bin/compiz --replace as startup application. That will do the trick.

auh2o
May 1st, 2010, 05:08 PM
I have the same problem, after upgrading to 10.04. After every restart, I need to:


Turn ON visual effects
Re-import my Compiz configuration profile into the Compiz Settings Manager (this might be because when I turn on visual effects, in my case the "Extra" option, the default Extra settings will be applied, and my settings are substantially different.)
Reload Compiz via the Fusion icon to get the window borders to reappear


I found this workaround in other thread here, add
/usr/bin/compiz --replace as startup application. That will do the trick.

That works, for now. But it is as you say a workaround, not a solution. ;-)

_0R10N
May 1st, 2010, 05:15 PM
I have the same problem, after upgrading to 10.04. After every restart, I need to:


Turn ON visual effects
Re-import my Compiz configuration profile into the Compiz Settings Manager (this might be because when I turn on visual effects, in my case the "Extra" option, the default Extra settings will be applied, and my settings are substantially different.)
Reload Compiz via the Fusion icon to get the window borders to reappear



Did you tried what I suggested in the previous comment?

_0R10N
May 1st, 2010, 05:20 PM
I subscribed to the bug report relating this problem, and I've just received an email notification, suggesting the following workarounds:

a. Having selected effects as above, select "Remember running applications" from Startup Applications
b. Invoke /usr/bin/compiz --replace as a startup application
c. ln -s /usr/bin/compiz /usr/bin/compiz.real
d. Invoke /usr/bin/metacity from command line or as a startup application

I hope this help.

dchenbecker
May 6th, 2010, 05:09 PM
Just adding "/usr/bin/compiz --replace" as a startup app seems to get things going just fine for me.

_0R10N
May 6th, 2010, 05:16 PM
I updated the kernel and other packages, last night. I'll remove the /usr/bin/compiz --replace of my startup applications list and see if it still working properly.

I'll let you know.

nutellajunkie
October 9th, 2010, 11:58 AM
I updated the kernel and other packages, last night. I'll remove the /usr/bin/compiz --replace of my startup applications list and see if it still working properly.

I'll let you know.

did it blow up?