PDA

View Full Version : [ubuntu] That pesky sound - iMac 7,1, Intrepid



MacManUI
February 26th, 2009, 01:10 AM
I don't think it's actually possible for me to come up with another way to search this out in the forums or on Google, so I've decided to go the asking route.

I got the sound working on my iMac following the instructions in several guides. I think the final piece was the snd-hda-intel=imac24 (even though it's a 20", which just makes me smile).

Though the sound works, it sounds like it's coming out of a tin can (one of the twenty or so descriptions I've used in searches). Volume level is great - almost piercing with the low-quality.

I've tried enabling mysterious surround speakers in several configurations. I've tried downgrading, upgrading, reinstalling. It wouldn't be so bad but I also haven't been able to get the audio out to work, so I can't even shunt it to my external amp.

When I run the channel test I get left and right channels, but when anything is actually playing it pretty much sounds like someone is holding a can right behind the Apple logo on the front of the machine.

If there's a solution, great. If not, I'd just love for someone to tell me that's all the better it's gonna get so I can quit looking around. So far, I've found neither answer.

Thanks all!

cyberdork33
February 26th, 2009, 03:57 AM
well, just a guess, but there are issues with a subwoofer not being activated on some of the portables, maybe there is one on the newer iMacs as well...

joecefiro
March 2nd, 2009, 11:14 AM
Mine is exactly the same as you are describing so you are not alone. Subwoofer???

joecefiro
March 2nd, 2009, 11:20 AM
Also headphone port not working

MacManUI
March 2nd, 2009, 04:57 PM
Yeah - I tried several suggestions on how to enable different speakers in order to locate the mysterious subwoofer, all to no avail.

And the headphone jack thing too.

If I weren't such an audiophile it'd be ok, but it's hard to use Ubuntu as my primary OS when I can't listen to music.

cyberdork33
March 2nd, 2009, 05:49 PM
Since there seems to be several of you, coordinate on a bug report.

jeffmings
April 14th, 2009, 05:17 AM
Hello!

I submitted a bug report for this issue as https://bugs.launchpad.net/bugs/360866 . I hope we can get this resolved. I have been using Linux as my OS of choice since Redhat 5.1, and would love to be able to enjoy good sound running Jaunty Jackalope on my aluminum iMac :)

Aloha,
-Jeff Mings

MacManUI
April 14th, 2009, 07:12 AM
Found this info, now everything is working just fine. Obviously a lot to go through to get sound working, but it was the hunting for the info that was the worst part...

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4086

311005901
June 14th, 2009, 02:43 PM
You may want to check out this post (http://ubuntuforums.org/showpost.php?p=7454958) to see if that fixes your problem.