PDA

View Full Version : [ubuntu] Toggle Workspaces



alanfang
February 25th, 2009, 04:31 AM
Is it possible to toggle workspaces with a keyboard shortcut in ubuntu? Right now I can shift one left, or shift one right. Once I get to the end of the line though it doesn't wrap around to the other side, it just stops. Is there any way to achieve what I am looking for?

llamabr
February 25th, 2009, 04:38 AM
You want to continue past two, to get back to one?

Interestingly, this appears to be a problem for gnome. XFCE and KDE do it, as does windowmaker.

Look here:

http://reachbeyondgrasp.blogspot.com/2008/01/wrapping-workspaces-in-gnome.html

Zevik
February 25th, 2009, 04:40 AM
The best way to go about doing this is to enable Compiz-Fusion and the Advanced Desktop Effects. You can check out my fairly straightforward guide HERE (http://gn00buntu.blogspot.com/2009/01/me-look-pretty-one-day.html). After installing the proper packages, go to the Compiz-Config Settings Manager and there are several options available under desktop. If you dont want the desktop cube, I would suggest enabling the Expo plugin.

llamabr
February 25th, 2009, 04:45 AM
I don't use compiz, but keep in mind that some users complain that it interferes with movies and some video. It's also not the best solution for old systems, or those with less than optimal video cards.

If you're unhappy with compiz, post back for other solutions.

alanfang
February 25th, 2009, 04:54 AM
Yes I want to keep going past two to get to one.

I would rather not enable advanced desktop effects given the limited system resources on my laptop.

RyanVanDiemen
February 25th, 2009, 03:45 PM
this is actually one of the reasons why I switched recently from gnome to KDE. I couldn`t figure out how to switch between desktops without using arrows and nobody was able to help me. Strange that such advanced desktop as gnome definitely is doesn`t have this funcionality...

llamabr
February 25th, 2009, 03:47 PM
How do you do so in kde without using the arrows?

In gnome, also, you can put the cursor on the edge of the screen, and using the scroll wheel change between them. I discovered this feature by accident.

It does seem strange that this is not possible in gnome. I used it all the time in wmaker.

I guess this is an issue with the desktop manager, not the window manager, so you could try running xfce or something else inside of gnome. that would solve it.

RyanVanDiemen
February 25th, 2009, 05:01 PM
In KDE you just Ctrl+F1 (f2,f3 etc.)...

twistedtwig
March 26th, 2009, 11:16 PM
Windows E

http://www.technotraits.com/2008/11/25-useful-ubuntu-shortcuts/

xored
January 8th, 2010, 01:22 AM
When you using Compiz on normal or special mode (Karmic or Intrepid) you will not able to use wmctrl to use switch the workspaces the described way (you will only have one workspace). I have described the way to accomplish that here

http://wiki.impressive-media.de/doc/...ctivated-gnome (http://wiki.impressive-media.de/doc/toggle-or-rotate-through-your-workspace-using-a-shortcut-while-having-compiz-activated-gnome)