View Full Version : [ubuntu] Couldn't install grub boot loader

February 24th, 2009, 04:10 PM

I'm new to ubuntu but I really like it, I installed it on my desktop and an older laptop for my son no problem, but I'm having trouble installing it on my laptop (AMD64 x2, vista-yuck)](*,) i've tried the cd and Wubi - then last night I downloaded the alternate cd that was going fine but it wouldn't install the grub boot loader it said:-

boot manually with the /vmlinuz kernel on partition /dev/sda9 and root=/dev/sda9 passed as a kernel argument :confused:

can anyone explain to me exactly how I do that please, :redface:


February 24th, 2009, 04:20 PM
Well the alternate CD is fine but maybe we don't need to go there just yet. When you try to install from the standard LiveCD, what prevents you? Do you get an error message, a system lock-up or what?

Also, do you know, or can you get, some of the basic specs of the PC you're trying to install on? How much RAM it has what graphics chipset or video card it's running could prove very helpful. Anything else you could get would icing.

Sometimes getting a LiveCD to boot is just a matter of a tweak on the GRUB line or something simple like that. And installing from the LiveCD really is my preferred method.

February 24th, 2009, 05:36 PM
When I try the live cd it stops before it gets to ubuntu install screen does nothing - it says something like, aperture beyond 4GB ignoring then stops

It's an iQon laptop
Processor AMD Athlon(tm) 64 X2 Dual-Core Processor TK-53, 1700 Mhz, 2 Core(s), 2 Logical Processor(s)
Graphics NVIDIA GeForce Go 6100?
Total Physical Memory 1,982.06 MB
Hitachi HTS541612J9S SCSI Disk Device 111.79 GB


February 24th, 2009, 08:54 PM
First thing to look at is your install media; this is probably the single biggest source of problems like this one.

Try re-burning the CD at a slow speed (like 8x or 16) and retry installing.

February 26th, 2009, 03:20 PM
i turned off bios legacy support and it works now