View Full Version : [ubuntu] Error in system-tools-backends

February 24th, 2009, 12:37 AM
Has anybody else been getting an error in the last few days whenever they update/upgrade? I keep getting this error about system-tools-backends:

The following partially installed packages will be configured:
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Setting up system-tools-backends (2.6.0-1ubuntu1.1) ...
* Starting System Tools Backends system-tools-backends
invoke-rc.d: initscript system-tools-backends, action "start" failed.
dpkg: error processing system-tools-backends (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

February 24th, 2009, 01:35 AM
Try removing the package then reinstalling it.

sudo apt-get remove system-tools-backends This will probably remove fast-user-switch-applet, gnome-applets, gnome-system-tools and liboobs-1-4 but you can reinstall those after you have reinstalled system-tools-backends.

sudo apt-get install system-tools-backendsthen

sudo apt-get install fast-user-switch-applet gnome-applets gnome-system-tools liboobs-1-4 ubuntu-desktop

February 24th, 2009, 01:46 AM
When I tried removing it before it said it was going to remove ubuntu-desktop, so I canceled it. But I did what you said and it worked. Thanks.

February 25th, 2009, 12:50 PM
Warning - for me this only works with apt-get as described. Synaptic introduces the same problem again

Also - while the problem exists some apps do funny things. On mine, Firefox wouldn't display the screen properly