PDA

View Full Version : [ubuntu] Installing nvidia driver = no more Xorg!



Selmer79
February 22nd, 2009, 04:05 PM
I have an nVidia 9300/730i motherboard and a GeForce 9800GTX in my computer, and Ubuntu 8.10 runs just fine with the default open-source nVidia driver.

The problem comes when I try to install the closed-source driver from nVidia.

I've tried both the 177-driver from the repository and the 180.29 driver from nvidia.com, and both times they install fine but Xorg won't start once I reboot.

I'd like to get CUDA installed so that I can do GPU-boosted computing for BOINC, but I'm stuck atm..

Anyone know of a fix?

Rotaj
February 22nd, 2009, 06:01 PM
Just to get this question out of the way, did you try this command in a terminal window?


sudo dpkg-reconfigure xserver-xorg

alexandari
February 22nd, 2009, 06:07 PM
Copy the output here when you try to start your X :}

also try rm /tmp/.X0-lock

and then startx (I suggest you do it under root)

Selmer79
February 22nd, 2009, 07:13 PM
@Rotaj: Tried that with FrameBuffer on and off, resulted in the following error when I ran startx:

Primary device is not PCI.
No devices detected.
No screens found.

@alexandari: No such file found.

I wrote down the error I get when I run startx with the default nvidia-generated xorg.conf from the 180.29 driver:

Failed to load module "type1" (module does not exist,0).
No devices detected.
No screens found.

I found no reference to any "type1" module in xorg.conf, so I'm stumped.

Selmer79
March 4th, 2009, 07:04 PM
Bump...

C--
March 4th, 2009, 10:49 PM
Did you try running


nvidia-xconfig

as root?

neppakyo
March 4th, 2009, 10:51 PM
Also, 180.35 is avaialble.

Im using it on jaunty

linfidel
March 4th, 2009, 11:07 PM
Don't know if any of this will help, but I recently had problems getting Compiz and the restricted driver to work after it had worked for many different versions. I was having problems with Firefox, where it would periodically freeze for 5 - 10 seconds, so I wanted to see if it worked better without Compiz. I may have done the wrong thing, in that I ran "metacity --replace."

The upshot was that I couldn't get compiz or the restricted driver to run after that. What I had to do was to use the system monitor to end the metacity process; but it was more complicated than that, because once I did that, I had problems opening programs and using the keyboard (mouse worked OK). So, I had to do something like open the run dialog first, type in "compiz --replace", then stop the metacity process, and click on OK for the run dialog. I think opening the restricted driver window would also work.

It's a longshot, but you can play around and try it. It didn't seem to do any damage while I was playing around and repeatedly restarting X (Ctrl-Alt-Backspace).

darco
March 4th, 2009, 11:28 PM
Also, 180.35 is avaialble.

Im using it on jaunty

I wouldnt install 180.35 just yet, has a screensaver issue.....

darco

neppakyo
March 4th, 2009, 11:31 PM
I wouldnt install 180.35 just yet, has a screensaver issue.....

darco

I dont use screensavers, just monitor blank, and that works just dandy

hayalci
March 6th, 2009, 04:41 PM
Hi,

You should edit the folowing file as root:
/etc/default/linux-restricted-modules-common

And disable the nvidia modules that come with restricted drivers package.
DISABLED_MODULES="nv"

This prevents ubuntu from overriding the nvidia driver you have installed.
After a reboot, all should be fine if nvidia driver was installed correctly.