View Full Version : [ubuntu] problems with terminal

February 21st, 2009, 07:56 PM
iv been trying to get windows to launch on my ubuntu desktop and downloaded everything, now when i tried to install vmware player it worked the first time but it failed when it tried to make a new kernel because i forgot to install kernel hearder. now that i have whenever i go onto the terminal and enter:
cd vmware-player-distrib
it replies with 'bash: cd: vmware-player-distrib: No such file or directory'
now this doesn't make sense to me because the commands are based on my desktop (atleast it seems to say it is) and the uncompressed pkg is on my desktop, any help?

February 21st, 2009, 08:00 PM
Where are you in the directory tree when you run the command? Try this:

cd Desktop

You should see your file in the list. If you weren't in your Desktop directory, that was the problem. The default directory in the terminal is your /home/[your username] directory. Make sense?

February 21st, 2009, 08:20 PM
yeah it does, i just got confused cuz my command line is preceded by
so i assumed it was already at my desktop, but when i put that command it showed

new file~

i guess that solved it, i didn't know that u had to do all that stuff at once, thanks alot!

February 21st, 2009, 08:21 PM
one quick question though, when i put cd desktop alone y didn't it go to desktop?

February 21st, 2009, 08:26 PM
one quick question though, when i put cd desktop alone y didn't it go to desktop?

It depends on where you are in the directory tree :-).


by itself puts you back into your home directory, which is where your Desktop directory lives. Alternately you can do

cd ~/Desktop

The ~/ means your home directory.

Oh - and the reason "cd desktop" won't work is that capitalization matters in Linux. It has to be cd Desktop.

February 21st, 2009, 08:37 PM
wow, well thats definately good to know, thanks alot once again